Closed Bug 637605 Opened 9 years ago Closed 8 years ago

nsDOMClassInfo.h:262:26: warning: inline function ‘static nsresult nsDOMClassInfo::WrapNative(...)’ used but never defined

Categories

(Core :: XPConnect, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 648359

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [build_warning])

Filing bug on this recently-introduced build warning:

dom/base/nsDOMClassInfo.h:262:26: warning: inline function ‘static nsresult nsDOMClassInfo::WrapNative(JSContext*, JSObject*, nsISupports*, nsWrapperCache*, const nsIID*, jsval*, nsIXPConnectJSObjectHolder**, PRBool)’ used but never defined

Referenced code is:
> 262   inline static nsresult WrapNative(JSContext *cx, JSObject *scope,
> 263                                     nsISupports *native, nsWrapperCache *cache,
> 264                                     const nsIID* aIID, jsval *vp,
> 265                                     nsIXPConnectJSObjectHolder** aHolder,
> 266                                     PRBool aAllowWrapping);
http://mxr.mozilla.org/mozilla-central/source/dom/base/nsDOMClassInfo.h
which was added 2 weeks ago, in http://hg.mozilla.org/mozilla-central/rev/52246c1b1799 (bug 614347).

I don't entirely understand the consequences of this build warning (I'd think it'd mean that the build would fail), but I'm pretty sure it's a Bad Thing.  See also bug 615834.

From a tinderbox clobber-build log, we've got 39 instances of this exact warning.  (once per compilation unit that includes the .h file, I imagine)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648359
You need to log in before you can comment on or make changes to this bug.