If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Account Manager doesn't complain if window isn't closed via Cancel

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
P2
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 12/26 trunk (tip)

Steps to Reproduce:

(1) Delete your profile, or create a new one.
(2) Open Navigator.
(2) File > New > Message.
(3) Close the Account Wizard via any method that the OS provides (close box, 
alt+F4, etc.)

Result: the confirmation that appears when pressing Cancel doesn't appear, and 
the message compose window doesn't go away (so it's a dead window).

This confirmation needs to happen onunload (with a check to make sure that 
onunload isn't being called normally when the wizard has been successfully 
completed).
Racham owns the Account Manager now, I believe.
Assignee: sspitzer → racham
QA Contact: esther → stephend

Updated

17 years ago
QA Contact: stephend → nbaca
(Reporter)

Comment 2

17 years ago
This should be fixed.  If the user exits the wizard in any other way but the 
Cancel button (which will happen often), we don't exit gracefully, and thus the 
whole app is broken.  Same, of course, happens if you're opening MailNews.
Keywords: mozilla0.9.1, nsbeta1, nsCatFood

Comment 3

17 years ago
marking nsbeta1+.  Not scheduling for the moment.
Whiteboard: [nsbeta1+]

Updated

16 years ago
Blocks: 104166

Updated

16 years ago
Keywords: nsbeta1+
Whiteboard: [nsbeta1+]

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274
(Reporter)

Comment 4

16 years ago
Maybe this isn't a problem with the new account wizard?
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
Hi

I have tested this using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.5b) Gecko/20030725 
and I am no longer seeing this issue.

Reporter can you please retest with a current mozilla build, and see if it is
gone for you too. ?

Please resolve the bug as appropriate or let us now if you still see it.

Comment 7

13 years ago
(In reply to comment #6)
> Please resolve the bug as appropriate or let us now if you still see it.

WFM too with a Linux trunk build from yesterday.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.