Insertion of separators in Personal Toolbar causes crash

VERIFIED DUPLICATE of bug 62401

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED DUPLICATE of bug 62401
17 years ago
12 years ago

People

(Reporter: L.M. de Vries, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash, regression})

Trunk
mozilla0.8.1
x86
Windows ME
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Open the manage bookmarks component.
Insert a separator in one of your folders on the personal toolbar.
PROBLEM 1: Separator is not shown at first.
Close Manage Bookmarks.
Re-Open Manage Bookmarks. Now the separator is shown.
Restart Mozilla.
MAIN PROBLEM: Now the separator magically results into multiple separators.
After some time (restarting mozilla several times) the number of separators can
be more than 50!
Manually deleting the separators works, but on exit mozilla will crash.

Comment 1

17 years ago
Maybe something related to bug 54866: "Importing ns4 bookmarks does not filter
out bad chars. Recursion happens."
See also its dupes.

Comment 2

17 years ago
Definate duplicate marking as such

*** This bug has been marked as a duplicate of 54866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Ksosez: Are you sure this is a dupe? I certainly isn't.
(Reporter)

Comment 4

17 years ago
I think you're right that it could be caused by importing Netscape 4 Bookmarks.
When I create a new account with new bookmarks and try the same thing, I do not
have any problems with the separators.

Comment 5

17 years ago
I'm not convinced this is a dupe yet...

Comment 6

17 years ago
I'm not either...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

17 years ago
Created attachment 22890 [details]
Small Bookmarks file that will cause crash,when inserting separator
(Reporter)

Comment 8

17 years ago
Mozilla Build: 2001011604 (WinME)
I have removed everything from my bookmarks-file, except for 1 folder in the
Personal Toolbar.
When inserting a separator into this folder, mozilla will crash on exit.
This smaller version of my bookmarks file does NOT have the multplying separator
problem, but I do think that the crash is related. That's why I have attached
the small bookmarks-file to this bug

Comment 9

17 years ago
tell me again the steps so I can reproduce this crash with the BM file you've attached
(so I can confirm this bug and check other platforms)

Comment 10

17 years ago
Marking NEW while you guys figure this out.
Status: UNCONFIRMED → NEW
Ever confirmed: true
When I try to do this in a Linux debug build I can reproduce the crash on exit.
 Attaching stack trace...
Created attachment 25029 [details]
stack trace

Comment 13

17 years ago
Adding crash, regression keyword.

Triaging the Most doomed (which Happens to Ben right now :)
Severity: normal → major
Keywords: crash, regression

Comment 14

17 years ago
Gotta fix this, setting target milestone to mozilla0.8.1, reassigning to pchen
to investigate crash
Keywords: nsbeta1
Target Milestone: --- → mozilla0.8.1
I see this too, only after adding a separator. Curiously, the crash seems to be 
spawned by the pref shutdown procedure. cc'ing alec who may be able to provide 
some insight...

Comment 16

17 years ago
the crash in the stack trace is the crash in bug 62401 (mozilla 0.8.1) - so I
don't know if you want to remove the 'crash' attribute of this bug, but I'd
recommend it..
Making dependant on 62401, removing the crash keyword per recommendation. 
Depends on: 62401
swapping dependency for dup since there's no problem with the separator 
insertion itself, there's just an additional crash

*** This bug has been marked as a duplicate of 62401 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
No longer depends on: 62401
Resolution: --- → DUPLICATE

Comment 19

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.