Build problem under Solaris

VERIFIED DUPLICATE of bug 21138

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 21138
17 years ago
13 years ago

People

(Reporter: jim_nance, Assigned: Scott Collins)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I am trying to build mozilla under Solaris 7 using the Workshop 6.0
compilers.  I am getting some fatal errors from the C++ compiler:

nsAtomTable.cpp
"nsAtomTable.cpp", line 63: Warning (Anachronism): Formal argument f of type
extern "C" int(*)(PLHashEntry*,int,void*) in call to
PL_HashTableEnumerateEntries(PLHashTable*, extern "C"
int(*)(PLHashEntry*,int,void*), void*) is being passed
int(*)(PLHashEntry*,int,void*).
"../../dist/include/nsAlgorithm.h", line 76: Error: Formal argument iter of type
unsigned short**& in call to static nsCharSinkTraits<unsigned
short*>::write(unsigned short**&, unsigned short*const*, unsigned) is being
passed unsigned short*.
"nsAtomTable.cpp", line 113:     Where: While instantiating
"copy_string<nsReadingIterator<unsigned short>, unsigned
short*>(nsReadingIterator<unsigned short>&, const nsReadingIterator<unsigned
short>&, unsigned short*&)".
"nsAtomTable.cpp", line 113:     Where: Instantiated from non-template code.
"../../dist/include/nsAlgorithm.h", line 76: Error: Formal argument s of type
unsigned short*const* in call to static nsCharSinkTraits<unsigned
short*>::write(unsigned short**&, unsigned short*const*, unsigned) is being
passed const unsigned short*.
"nsAtomTable.cpp", line 113:     Where: While instantiating
"copy_string<nsReadingIterator<unsigned short>, unsigned
short*>(nsReadingIterator<unsigned short>&, const nsReadingIterator<unsigned
short>&, unsigned short*&)".
"nsAtomTable.cpp", line 113:     Where: Instantiated from non-template code.
2 Error(s) and 1 Warning(s) detected.

Comment 1

17 years ago
adding some unix gurus to the bug.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 21138 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified as dup of bug 21138 - Compilation of src with Sun Workshop 6 fails at 
various points...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.