The folder Inbox is full, and can't hold any more messages.

RESOLVED DUPLICATE of bug 608449

Status

SeaMonkey
MailNews: General
RESOLVED DUPLICATE of bug 608449
7 years ago
7 years ago

People

(Reporter: dmi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier:  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11

"To make room for more messages, delete any old or unwanted messages and compact the folder."
I deleted many megabytes of old messages, and moved many thousands of other messages to other folders,
repeatedly compacting folders and emptying trash.
When I did so it was sometimes able to get a few new messages, no where near as much as I deleted,
then I would get the full message again,
But now after getting a few new messages, deleting and compacting no longer seems to make room for more messages.

Furthermore, in the process of deleting, moving, and compacting, I stated getting alerts saying
the file mailbox:///...?number=-441896 cannot be found. please check the location and try again.
This seems to happen for all mailboxes and all messages, with different numbers and paths.
One of the mailboxes still seems to have room for new messages, and messages are still downloading, and I can see the new headers, but trying to click on any of them produces the above messages,


Reproducible: Always

Steps to Reproduce:
1. attempt to read a mail message
2.
3.
Actual Results:  
Alert
The file mailbox:///...?number=-441896 cannot be found. please check the location and try again.

Expected Results:  
I need to be able to read my mail messages.



I still see text in the text of messages in Inbox files, so I'm guessing that Inbox.msf files have been corrupted.  Is there  way to reconstruct them?

Comment 1

7 years ago
> I still see text in the text of messages in Inbox files, so I'm guessing that
> Inbox.msf files have been corrupted.  Is there  way to reconstruct them?
Yes, just delete the .msf files. They will be recreated the next time SeaMonkey is started.

Updated

7 years ago
Severity: critical → normal
(Reporter)

Comment 2

7 years ago
That didn't work, but it gave me enough hints to find what seems to be the real problem.

Compact Folders does not seem to work on files larger than 4GB.
After manually trimming the file below 4GB, Compact Folders was then able
to compact down the deleted files, which then made room for new messages,
which I was able to see after the .msf files were rebuilt.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608449
You need to log in before you can comment on or make changes to this bug.