Case insensitivity to saved usernames and passwords

VERIFIED DUPLICATE of bug 499649

Status

()

--
major
VERIFIED DUPLICATE of bug 499649
8 years ago
8 years ago

People

(Reporter: ch10b068, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Supposing I create a username, say firefox on some website and log in, click "remember password", the username "firefox" is saved. If I want to log in as FIREFOX or Firefox or FIREfox, it is not possible as the browser assumes its a typo and changes everything to small case. 

Reproducible: Always

Steps to Reproduce:
1.Just put in a upper case letter in your username in any site. 
Say, Firefox instead of firefox ( the password for "firefox" is saved)
2.The browser will automatically change it back to "firefox"
3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499649
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.