Closed Bug 637808 Opened 9 years ago Closed 9 years ago

Focusing on a text field element may give you a console error : "focusedElement is null" in common-ui.js line 738

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: nhirata, Assigned: mfinkle)

Details

Attachments

(1 file)

Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110301 Firefox/4.0b13pre Fennec/4.0b6pre
Device: Droid 2 
OS: Android 2.2

1. go to http://people.mozilla.com/~nhirata/html_tp/formsninput.html
2. click in the first text field and type something
3. click on the second text field
4. go to the error console

Expected: no errors
Actual:
Error: focusedElement is null
Source File: chrome://browser/content/common-ui.js Line: 738

Note:
1. can also receive this error message on Amazon search field and Google search field.
Let's look at this one
Assignee: nobody → 21
tracking-fennec: --- → 2.0+
Assignee: 21 → mark.finkle
I am unable to reproduce on linux desktop and nexus one
Attached patch patchSplinter Review
I can add a simple null check for the code in question
Attachment #516149 - Flags: review?(21)
(In reply to comment #3)
> Created attachment 516149 [details] [diff] [review]
> patch
> 
> I can add a simple null check for the code in question

I'm unable to reproduce too but I imagine that a null check won't hurt.
pushed:
http://hg.mozilla.org/mobile-browser/rev/61d6d5dbabfe
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110317 Firefox/4.0b13pre Fennec/4.0b6pre
Device: Droid 2 
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.