Profile with Bookmarks button that is never visible

RESOLVED DUPLICATE of bug 581238

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 581238
7 years ago
7 years ago

People

(Reporter: B.J. Herbison, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.63 KB, application/rdf+xml
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre

While exploring bug 637792 I tried putting the Bookmarks Menu button into various toolbars. After moving things around several times I ended up with a profile with the Bookmarks Menu button in the Tab Bar but not visible:  I toggle the visibility state of the Menu Bar and the Bookmarks Menu button never appears.

If I Customize... the UI the Bookmarks Menu button shows up, but it vanishes when I click Done. The state persists when I exit and restart the browser.

I'll attach the localstore.rdf -- let me know if you need additional information about the profile.

Reproducible: Couldn't Reproduce
(Reporter)

Comment 1

7 years ago
Created attachment 515971 [details]
localstore.rdf
With this localstore I'd expect the button to be visible under the bookmarks toolbar as a "bookmarks" button.
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> With this localstore I'd expect the button to be visible under the bookmarks
> toolbar as a "bookmarks" button.

You are right, the Bookmarks toolbar is enabled and it shows up there. (I didn't notice it as I was looking for something without the text and with a down-arrow on the right side.)

But when I click customize the "Bookmarks" vanishes from the right side of the Bookmarks toolbar and the "Bookmarks Menu Button" appears on in the Tabs toolbar.

It seems confusing to me that the menu is moved from where I placed it and the "Customize" view shows the widget where it doesn't appear, but if that is the intent than mark this bug as invalid.
yes, it is confusing, but that is bug 581238 that we'll kick in a next version, so this ends up being a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581238
You need to log in before you can comment on or make changes to this bug.