reporter-lib git clone failing on django-cache-machine

RESOLVED INVALID

Status

Input
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: ryansnyder, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

git clone --recursive git://github.com/fwenzel/reporter-lib.git vendor

...

Cloning into src/django-cache-machine...
fatal: The remote end hung up unexpectedly
Clone of 'git://github.com/jbalogh/django-cache-machine.git' into submodule path 'src/django-cache-machine' failed
Try again? Perhaps github hiccups. I checked, and the repository still exists:
https://github.com/jbalogh/django-cache-machine
Yeah, it took 25 attempts, but finally pulled successfully.  It hung up the first few times on django-cache-machine so I assumed that was the error.  Then it started hanging on other modules.  Anyhoo...
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
:(
Did it ever hang?  What box was this on?  Did you do any other investigation as to the cause?  Has it happened before?  Has it happened with other repositories?  Were they on github?
This particular instance was from my laptop.  Git dropped connection on various modules that are hosted on github, including django-cache-machine, django-nose, django-cronjobs, django-mozilla-product-details, and commonware.

Yes, I've seen this before, and I know others have had problems with dropped connections.  But I don't think anyone has looked into the issue.
FWIW, sometimes our staging-update cron jobs error out with a similar error but recover on their next run, so I always attributed that to temporary problems somewhere between here and github.
(Assignee)

Updated

7 years ago
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.