Closed Bug 637892 Opened 9 years ago Closed 9 years ago

Pressing backspace on Xoom keyboard results in us deleting 2 characters

Categories

(Core :: Widget: Android, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: pavlov, Assigned: mwu)

Details

(Keywords: inputmethod, Whiteboard: [vkb])

Attachments

(1 file, 2 obsolete files)

Go to any text field in Fennec on a Xoom (using the stock Honeycomb keyboard) and type some text.  Pressing backspace to delete a letter will delete 2 letters.
tracking-fennec: --- → ?
Keywords: inputmethod
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [vkb]
Assignee: nobody → crowderbt
tracking-fennec: ? → 2.0+
mwu is taking a look at this one
Assignee: crowderbt → mwu
mwu, this works fine on the xoom but is busted on the nexus one.  Clearly, i am new to this code and do not think that this is a real fix, just wanted to share something with you that was working better.

ooc, i really don't understand why we have a separate path for deleting a character.
Comment on attachment 517658 [details] [diff] [review]
patch v.1 - onTextChanged playground

basically what this does is prevents the delete from happening.
Attachment #517658 - Attachment is obsolete: true
the keyboard on the XOOM is sending a keypress when you click on the delete button.  This is the cause of the two deletes -- one we generate from onTextChanged, and the other from the actual keyboard.

We probably can handling this in a few ways -- like special case the xoom in the GeckoInputConnection, or disable keypresses that use the delete (which would hurt webcontent).
Attached patch patch v.1 (obsolete) — Splinter Review
illustration only.

this prevents keypresses with the delete key from being seen by gecko.  The keyboard now works fine(*) on Xoom and g2.
This prevents the hkb code (which involves mKeyListener, onTextChange, and others) from being invoked when the softkb is generating key events.
Attachment #517660 - Attachment is obsolete: true
Attachment #517794 - Flags: review?(doug.turner)
Comment on attachment 517794 [details] [diff] [review]
Do not filter keyevents from the soft kb

tested on the xoom and the g2 (both hardward keyboard and software keyboard).
Attachment #517794 - Flags: review?(doug.turner) → review+
http://hg.mozilla.org/mozilla-central/rev/acb121c0e340
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.