Saving all attachments from multiple selected emails at once seems possible, but is not

RESOLVED DUPLICATE of bug 92146

Status

--
enhancement
RESOLVED DUPLICATE of bug 92146
8 years ago
8 years ago

People

(Reporter: vuilnisbakvoorspam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.14) Gecko/20110221 Thunderbird/3.1.8

When selecting multiple e-mails, containing attachments, wouldn't it be handy to make the "file > attachments > save/detach/remove all"-function affect all attachments in the selected emails ? 

Some counterintuitive things that arise now :
- In the current situation (latest release, just fresh installed), when selecting multiple attachment-containing messages using the CTRL-click method, the "file > attachments..." menu is not greyed out but shows *only* the attachments of the first selected email (!) 
- The menu is completely greyed out when the mail-selecting process starts with a non-attachment email, followed by (an) attachment-mail(s)

I saw that some ideas were exchanged in bug 282068 and bug 466060 about attachment handling, however these discussions are dealing with the attachment area and this with the main-menu, therefore my posting.

Reproducible: Always

Steps to Reproduce:
1. Select >1 emails, all containing attachments, one by one (using CTRL + click)
2. Click "file > attachments..."
3. Do you see all attachments of all selected mails listed in that menu?
Actual Results:  
No, only the attachments of the first-selected email with attachments are shown in the menu and only these are 'saveable, detacheable and removeable'.

Expected Results:  
All attachments should be listed and directly saveable/detacheable/removable together, not only the attachments of the first-selected attachmentmail.
Whiteboard: dupme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 92146
Most of the problem description of comment 0 is not a duplicate of bug 92146. It describes a flaw in the UI whereby attachment menu will only offer whatever attachments are [not] present in the *first* selected mail, even when the actual focus is already on another mail (which may have different or no attachments). Until bug 92146 gets fixed, imo the correct interim behaviour should be this:

Expected behaviour:

When multiple emails are selected, attachments menu should always be disabled.

We should either reopen this bug or file a new one to fix this confusing ui (before fixing 92146, which will certainly land much later, as I assume it is harder to fix).
You need to log in before you can comment on or make changes to this bug.