[CBX][DUP]Scrollbar always present in "select size=x" field

VERIFIED DUPLICATE of bug 45731

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED DUPLICATE of bug 45731
17 years ago
16 years ago

People

(Reporter: Eric Vaandering (no email), Assigned: rods (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If a select with "SIZE" attribute is specified, there is always a scrollbar
present, even if the number of possible values is less than SIZE. This has the
possibility of confusing the user who may wonder what is below what is visible
in the list.

Netscape 4.x does not have this behavior.

Comment 1

17 years ago
The only bug I can find that is close to this is bug 5589, and then only in a
reference to an unlisted (and maybe unrelated) spinoff bug.

http://bugzilla.mozilla.org/query.cgi shows several instances of this bug.

Confirming on Linux 20001229
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
Low priority, this will be fixed when we go to XBL form controls
Priority: -- → P3
Target Milestone: --- → Future
(Assignee)

Comment 3

17 years ago
I think this is a dup 
Status: NEW → ASSIGNED
Summary: Scrollbar always present in "select size=x" field → [CBX]Scrollbar always present in "select size=x" field
(Assignee)

Updated

17 years ago
Summary: [CBX]Scrollbar always present in "select size=x" field → [CBX][DUP]Scrollbar always present in "select size=x" field

Comment 4

17 years ago
I think this bug should be taken more seriously than the existing comments
appear to take it.  Note that the problem is not simply that the scrollbar
is present, but that the small size of the thumb implies there are many more
entries to scroll.  The effect is particularly compelling when the list elements
exactly fill the box, so even the visual cue of a blank space below the list
elements isn't present.  

I spent several moments trying to scroll one of the lists on
http://bugzilla.mozilla.org/query.cgi, then decided it was a bug, but
misinterpreted its nature.  This may seem minor, but I suggest it could be
a significant source of usability confusion.

A simple fix would appear to be to check if all the list box elements are
visible without scrolling, and if so, make the thumb completely fill the
scrollbar (I don't personally care if it actually disappears).
The bug is still present in Mozilla 0.9.4, linux, gtk.
(Reporter)

Comment 5

17 years ago
*** Bug 104212 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 45731 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.