Closed Bug 638070 Opened 10 years ago Closed 10 years ago

Applet support broken on page reload since 3.6.14

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 629030

People

(Reporter: martin.zipperling, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14

Java applets fail to be load properly when the page is reloaded multiple times. This worked w/o problems up to Firefox 3.6.13 but stopped working with 3.6.14

Reproducible: Always

Steps to Reproduce:
1. Make sure you have Java plugin installed (tested with 6.0.23 and 6.0.24)
2. Start Firefox 3.6.14 and go to (e.g.) http://java.sun.com/applets/jdk/1.4/demo/applets/TicTacToe/example1.html
3. TicTacToe applet will start up. Open the Java Console and trace level to 5 (all)
4. In Firefox, reload the page multiple times (usually after 3 or 4 reloads you will see some lengthy stacktraces in the Java Console)
Actual Results:  
Applet no longer works

Expected Results:  
Applet should remain usable after page reload

Stacktrace and other output in Java Console seems to imply that the Applet's codebase cannot be retrieved successfully, e.g.:

netscape.javascript.JSException: JavaScript error while getting property "document"
	at sun.plugin2.main.client.MessagePassingJSObject.newJSException(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.waitForReply(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.doMemberOp(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.getMember(Unknown Source)
	at sun.plugin2.main.client.MessagePassingExecutionContext.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getCodeBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$9.getCodeBase(Unknown Source)
	at sun.plugin.util.ErrorPanel.deniedCertificateFailure(Unknown Source)
	at sun.plugin.util.ErrorPanel.<init>(Unknown Source)
	at sun.plugin.util.GrayBoxPanel.setError(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.getGrayBoxPanel(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.paintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.repaintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.showLoadingError(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.showAppletException(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.showAppletException(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
java.lang.NullPointerException
	at sun.plugin2.applet.Plugin2Manager$9.getCodeBase(Unknown Source)
	at sun.plugin.util.ErrorPanel.deniedCertificateFailure(Unknown Source)
	at sun.plugin.util.ErrorPanel.<init>(Unknown Source)
	at sun.plugin.util.GrayBoxPanel.setError(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.getGrayBoxPanel(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.paintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.repaintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.showLoadingError(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.showAppletException(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.showAppletException(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
netscape.javascript.JSException: JavaScript error while getting property "document"
	at sun.plugin2.main.client.MessagePassingJSObject.newJSException(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.waitForReply(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.doMemberOp(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.getMember(Unknown Source)
	at sun.plugin2.main.client.MessagePassingExecutionContext.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getCodeBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$9.getCodeBase(Unknown Source)
	at sun.plugin.util.ErrorPanel.deniedCertificateFailure(Unknown Source)
	at sun.plugin.util.ErrorPanel.<init>(Unknown Source)
	at sun.plugin.util.GrayBoxPanel.setError(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.paintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.repaintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.access$200(Unknown Source)
	at sun.plugin.util.GrayBoxPainter$1.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
java.lang.NullPointerException
	at sun.plugin2.applet.Plugin2Manager$9.getCodeBase(Unknown Source)
	at sun.plugin.util.ErrorPanel.deniedCertificateFailure(Unknown Source)
	at sun.plugin.util.ErrorPanel.<init>(Unknown Source)
	at sun.plugin.util.GrayBoxPanel.setError(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.paintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.repaintGrayBox(Unknown Source)
	at sun.plugin.util.GrayBoxPainter.access$200(Unknown Source)
	at sun.plugin.util.GrayBoxPainter$1.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
I have exactly the same problem since I updated Firefox version to 3.6.14 (reloading or making several accesses to pages containing a Java Applet worked fine with Firefox 3.6.13, this is not the case anymore with Firefox 3.6.14).

The problem does not only occurs when you reload a page, but also if you access several times to the same page (e.g. by clicking a link). You need to exit then restart Firefox to be able to run the applet contained in the page again.

In my case the applet always fails to run at the second reload (or third access), strangely the first reload (or second access) works fine.
Seeing the same issue at screencast-o-matic.com.  Just started happening with 3.6.14

getDocumentBase() returns null after loading applet multiple times.  Killing java.exe process doesn't fix it.  You must restart FireFox.exe before it starts working again.
Depends on: 629030
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
No longer depends on: 629030
Resolution: --- → DUPLICATE
Duplicate of bug: 629030
You need to log in before you can comment on or make changes to this bug.