wacky behaviour after deleting linked inline image

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Tim Waugh, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior])

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18-ppa205a i586; en-US; m18)
Gecko/20001211
BuildID:    2000121118

After deleting a linked inline image in the editor, the toolbar no longer works
properly.

Reproducible: Always
Steps to Reproduce:
Make test.html:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body>
<a href="/tmp/test.jpg"><img src="/tmp/test.jpg" alt="alt"></a>
</body>
</html>

Make /tmp/test.jpg (any will do; doesn't even have to be a valid JPEG).

mozilla -edit
Click on 'open'
Select /tmp/test.html
Right-click on the image.
Select 'delete'.
Click on icons in the toolbar like 'Image', 'Open', etc.

Actual Results:  The toolbar icons no longer work (except for 'New').  The text
style icons are now greyed out.

Expected Results:  The toolbar buttons should work as before.

Comment 1

17 years ago
Confirmed

Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001010211 M18 Trunk Build

Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
at first I thought this had to do with nothing left in the file to edit, but 
that is not the case. I added text after the image and then brought it into 
Composer and the toolbar items were still disabled. I even selected the 
remaining text to see if that made a difference and it did not.
Assignee: beppe → jfrancis
Severity: normal → major
OS: Linux → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 3

17 years ago
requesting help here since there is the outside possibility it might not be me :-
)  charlie, simon, either of you have time to look at this one?

Comment 4

17 years ago
I suspect that the important part of the steps here is that the image is deleted 
via the context menu. I suspect some focus weirdness, which results in disabled 
controls.
(Assignee)

Comment 5

17 years ago
appeasing bug gods
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

17 years ago
Keywords: correctness
Whiteboard: [behavior]
(Assignee)

Comment 6

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
tim is this working for you now?

Comment 8

17 years ago
verified in 6/21 linux build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.