crashes [@ nsFrameManager::HandlePLEvent]

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: dbaron, Assigned: Chris Waterson)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
Around #10 or so on the topcrash list (for more information see
ftp://ftp.mozilla.org/pub/data/crash-data/ ) are crashes at
nsFrameManager::HandlePLEvent (nsFrameManager.cpp, line 902.  Could this be
related to changes to fix that other topcrash (in CantRenderReplacedElement)? 
It seems that aEvent->owner must be garbage (deleted?).

Comment 1

17 years ago
*** Bug 64095 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

17 years ago
Any known URLs for this? (I'm not seeing a whole lot of useful data today in the
`crash-data' directory. Looks like maybe the reports are wedged?
(Reporter)

Comment 3

17 years ago
Only the one in the duplicate bug.  I think the crash data have been
out-of-service since the new year or so.
(Assignee)

Comment 4

17 years ago
Yeah, tried the dup. There is no `popup' on that site anymore...

Comment 5

17 years ago
Here is the data from the last successful report that was run last 
wednesday...it's based on RTM topcrashers for all platforms (I hope it's the 
same crash):

FrameManager::HandlePLEvent   22                          
     First BBID : 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=23941646
     Last BBID  : 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=24000187
     Min Runtime :884
     Max Runtime :963529
     Min seconds since last crash :44
     Max seconds since last crash :287126
     First Appearance Date : 2001-01-02
     Last Appearance Date : 2001-01-03

Stack Trace: 

         FrameManager::HandlePLEvent()  
         PL_HandleEvent()  
         PL_ProcessPendingEvents()  
         nsEventQueueImpl::ProcessPendingEvents()  
         event_processor_callback()  
         our_gdk_io_invoke()  
         libglib-1.2.so.0 + 0xf340 (0x40662340)  
         libglib-1.2.so.0 + 0x10bd6 (0x40663bd6)  
         libglib-1.2.so.0 + 0x11203 (0x40664203)  
         libglib-1.2.so.0 + 0x113cc (0x406643cc)  
         libgtk-1.2.so.0 + 0x931dc (0x405821dc)  
         nsAppShell::Run()  
         nsAppShellService::Run()  
         main1()  
         main()  
         libc.so.6 + 0x18a5e (0x40267a5e)  
 
        Source File :  line : 

        URL:(23943214) AMM.com
        URL:(23943492) www.gate.net/webmail
        URL:(23967704) xoip.com
        URL:(23979837) http://valuekard.com/bin/KOARes/entry
        URL:(23984543) nfl.com
        URL:(24000187) www.wgsn.com
        Comment: (23941646) I started Netscape
        Comment: (23943214) downloading page to print
        Comment: (23943492) Printing
        Comment: (23949791) TRYING TO PRINT A READ ME DOC FROM AUTOCAD POINT A
        Comment: (23951714) exiting product registration
        Comment: (23952164) Trying to print address book
        Comment: (23967704) printing a page
        Comment: (23973540) I was editring Netscape preferences (code pages
        Comment: (23976723) printing  an email
        Comment: (23979837) Trying to print one of my emails.
        Comment: (23982279) program closed down
        Comment: (23984249) trying to print an email message
        Comment: (23986365) Printing an email
        Comment: (24000187) printing

Comment 6

17 years ago
Obviously it's something that has to do with printing...

Comment 7

17 years ago
936 //adding a ptr check since talkback is complaining about a crash here.
937 //I suspect that if the event->owner is really null, bad things will happen
938 //elsewhere.

Seems like someone checked in a nullcheck here. Is this bug still occuring in
talkback? Is this fixed?

Adding crash keyword.
Keywords: crash
(Reporter)

Comment 8

17 years ago
Probably a duplicate of the original form of bug 65800, which was fixed by the
fix to some other bug...
(Assignee)

Comment 9

17 years ago
This is no longer appearing in the topcrash list.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
Marking verified in the March 23rd build.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsFrameManager::HandlePLEvent]
You need to log in before you can comment on or make changes to this bug.