Frequent service unavailable errors on allizom

RESOLVED DUPLICATE of bug 645739

Status

addons.mozilla.org Graveyard
Code Quality
--
critical
RESOLVED DUPLICATE of bug 645739
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Details

(Reporter)

Description

7 years ago
We see frequent service unavailable errors on preview and next. The error goes away on reloading the page.

This is slowing down QA considerably. Please investigate.
(Assignee)

Comment 1

7 years ago
There's nothing in the logs.
Looks like any concurrent Selenium tests are killing the server:

oremj: stephend: http://nm-dash01.nms.mozilla.org/ganglia/graph.php?g=cpu_report&z=large&c=amo&h=pm-app-amo24.mozilla.org&m=load_one&r=hour&s=descending&hc=4&mc=2&st=1299099989
[1:07pm] oremj: lookks like cpu spiked to 100% during that test
Severity: major → critical

Updated

7 years ago
Assignee: server-ops → jbalogh
Component: Server Operations: Web Content Push → Code Quality
Product: mozilla.org → addons.mozilla.org
QA Contact: mrz → code-quality
Version: other → unspecified
Can you slow down the selenium tests?  PAMO is only 1 box.
(In reply to comment #3)
> Can you slow down the selenium tests?  PAMO is only 1 box.

We can (and looks like we'll have to, until this is fixed) run them only one or two at a time, but that's pretty limiting.  Has it always been only 1 box?  We haven't run into this issue before, FWIW.  But we can't "slow them down," precisely...
Did this get fixed with the recent changes?
(In reply to comment #5)
> Did this get fixed with the recent changes?

Yep, over in bug 645739.  w00t!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645739
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.