Closed Bug 638164 Opened 11 years ago Closed 11 years ago

Checkerboarding after zooming in, visiting other page, then going back in history

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: martijn.martijn, Assigned: mfinkle)

References

Details

(Keywords: regression)

Attachments

(1 file)

More or less a follow-up from bug 622601.

Steps to reproduce:
- Go to http://www.nu.nl
- Scroll down
- Zoom in (either by double-tapping on pinch-zoom)
- Tap on a link
- After the resulting has loaded, go back in history

Expected result:
- The http://www.nu.nl should get shown, scrolled down at the position where you left that page. (and should the previous zoom level be restored too?)

Actual result:
- I only get to see checkerboarding or a gray area on the Android device (Droid)
Firefox doesn't restore the zoom level, so I guess it's probably best to not restore the zoom level on Fennec, either.
Mark Finkle mentioned on IRC this is probably related to bug 617952.
Blocks: 617952
tracking-fennec: --- → ?
No longer blocks: 617952
Depends on: 617952
Should be fixed by Bug 638170.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
I can still reproduce it following the steps to reproduce from the bug:

I also made a video: http://www.youtube.com/user/qaioana#p/u/1/7drQ-wzXPqI

I press the system menu back button and it's still reproducing... Opening the man.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I forgot to mention the build id: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110316 Firefox/4.0b13pre Fennec /4.0b6pre 

Devices: Motorola Droid 2 (Android 2.2), HTC Desire (Android 2.2)
I can't reproduce it anymore, fwiw.
Hmm, I'm getting the checkerboarding at http://nu.nl when scrolling down to the bottom, then reloading the page. This is in portrait mode, using the Droid.
Well as you can see from the video I can still reproduce it, but only if I press the system back button... using the back arrow works fine...
Ah, indeed, I can also reproduce it, when using the system back button.
Duplicate of this bug: 638170
Attached patch possible patchSplinter Review
This patch fixes the issues in this bug and bug 638170. We need to test for other side affects
Attachment #519931 - Flags: review?(mbrubeck)
Attachment #519931 - Flags: review?(wjohnston)
Comment on attachment 519931 [details] [diff] [review]
possible patch

This fixes the issue for me.  Might not be the ideal fix, but this is probably the right one to ship for 4.0.
Attachment #519931 - Flags: review?(mbrubeck) → review+
Attachment #519931 - Flags: review?(wjohnston) → review+
I think this patch regresses bug 622601.
tracking-fennec: ? → 2.0+
The test build fixes this bug. For me, bug 622601 is already not working, I filed a new bug for it, bug 641794.
Ok, just did some more testing with the test build from comment 14. The test build from comment 14 fixes this bug, but I'm seeing checkerboarding for appr. 0.5s just prior before the new page has loaded.
I'm also getting a brief checkerboarding when the page gets restored into the right scroll position.
Confirming that with the build above on my Milestone, on back, I am not seeing
checkerboarding and the page is scrolled to where it was left off. Albeit the
page is not zoomed. I used the 'Statiseken' link on the bottom foot at nu.nl
Pushed to trunk, mobile-2.0, and relbranch:

http://hg.mozilla.org/mobile-browser/rev/4244c8402767
http://hg.mozilla.org/releases/mobile-2.0/rev/fc47c4a659b1
http://hg.mozilla.org/releases/mobile-2.0/rev/4244c8402767
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
verified FIXED on build:
    Mozilla/5.0 (Android; Linux armv7l; rv:2.1) Gecko/20110318 Firefox/4.0b13pre Fennec/4.0 ID:20110318114419
Status: RESOLVED → VERIFIED
Thanks Aakash. I can also verify that this bug has been fixed.
bugspam
Assignee: nobody → mark.finkle
You need to log in before you can comment on or make changes to this bug.