Courier-Imap: Cannot empty Trash can

VERIFIED FIXED

Status

MailNews Core
Networking: IMAP
P5
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: cls, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: need help for verify)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From time to time, my Trash folder changes its icon from the Trash can icon to
the regular folder icon.  If I exit the app and relaunch, the Trash can icon
comes back.  On top of this,  I get the following error dialog when I try to
"Empty Trash" from one of my four accounts in this profile:

The current command did not succeed.  The mail server responded: Invalid mailbox

Now, while I was telling sspitzer this on irc, I ran across another anomaly.  I
was playing with the folders for the second account and I was able to look in
the Trash folder.  It had a few messages so I decided to empty it.  Once I
clicked on "Empty Trash", the icon for the trash can flipped between the regular
folder and the Trash can a few times before returning back to the Trash can.
And then I got the previously mentioned dialog again and was unable to look at
the empty folder.

This occurred with a cvs build from about 2000-12-17 20:00 PST. The IMAP server
is running Courier-Imap 1.2 and my delete model is "Move To Trash".
cls, can you attach your prefs.js and an IMAP protocol log?
(Reporter)

Comment 2

17 years ago
Created attachment 21364 [details]
mail portion of prefs.js
(Reporter)

Comment 3

17 years ago
Created attachment 21365 [details]
imap protocol log
QA Contact: esther → stephend
(Reporter)

Comment 4

17 years ago
Looking at the log, the problem appears to be that somehow it determined that
"Inbox/Trash" was the name of the trash folder.  It should be "Inbox.Trash".  My
namespaces appear to be set correctly ("Inbox." & "shared.", respectively). 
I've also noticed that when I click on a folder, it spits out a uri to the
console:
In OnFolderLoaded for imap://cls%40seawood.org@mail.seawood.org/INBOX/announce

Where does that uri come from?  I'm pretty sure that if the uri used . instead
of / for the folder seperators, it would fix this problem.


6151[8621e68]: mail.seawood.org:A:SendData: 2 select "INBOX/Trash"
6151[8621e68]: mail.seawood.org:A:CreateNewLineFromSocket: 2 NO Invalid mailbox
5126[8cb62f8]: mail.seawood.org:S-INBOX.Trash:SendData: 5 select "INBOX/Trash"
5126[8cb62f8]: mail.seawood.org:S-INBOX/Trash:CreateNewLineFromSocket: 5 NO
Invalid mailbox

Comment 5

17 years ago
Are you using cyrus imap server. The problem appears to be with hierarchy
delimiter. Should not take long to fix. 
(Reporter)

Comment 6

17 years ago
Courier-imap.  I've been trying to track it down but there's a number of places
that hardcode / as the delimiter.  

Comment 7

17 years ago
There is no target milestone on this one... may be we should nominate.
(Reporter)

Updated

17 years ago
Keywords: mozilla0.8
(Reporter)

Comment 8

17 years ago
Should nsIImapUrl->AllocateCanonicalPath(....) always replace any delimiter that
you pass into it with / ?
 
(Reporter)

Comment 9

17 years ago
Sorry about the spam. An unset priority should be less than P5.  
Priority: -- → P5

Comment 10

17 years ago
This currently isn't planned for mozilla0.8.  I've changed the nomination to
mozilla0.9 so it gets properly triaged for the next milestone.


cc varada. I think he experienced this problem before.
Keywords: mozilla0.8 → mozilla0.9

Updated

17 years ago
Keywords: interop
Summary: Cannot empty Trash can → Courier-Imap: Cannot empty Trash can
QA Contact: stephend → huang

Comment 11

17 years ago
*** Bug 72053 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

17 years ago
Ok, I'm not sure what changed as I've been on a separate branch for a few weeks
but viewing items in the trash and emptying the trash can now works.  Whatever
change fixed the problem went in before 2001/05/23 as it works on the static
build branch cut on that date.
.

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
I think this may got fixed because of bug 79444

Comment 14

17 years ago
bug 79444 is fixed and has been verified for Cyrus IMAP.
This is Courier-Imap server....Courier-Imap.
Christopher, can you help for verifying this bug on Courier-Imap since we don't 
have the Courier-Imap server in the lab. Please marking as verified if problem 
is fixed. Thanks.

Updated

17 years ago
Whiteboard: need help for verify
(Reporter)

Comment 15

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.