[LAYER] java script does not work (www.tuniv.szczecin.pl)

VERIFIED FIXED

Status

P4
normal
VERIFIED FIXED
18 years ago
4 years ago

People

(Reporter: milcarz, Assigned: piskozub)

Tracking

Details

(Whiteboard: CentralEurope, URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

18 years ago
Under IE or Netscape 4.5* this page work with java script, but under mozilla 0.6
nothing appears :-(

Comment 1

18 years ago
top right menu use layers to display submenus.
Assignee: rogerl → evangelism
Component: Javascript Engine → Evangelism
QA Contact: pschwartau → zach
Summary: java script does not work → [LAYER] java script does not work

Comment 2

18 years ago
Marking "new". Reporter, this site uses non-standard javascript/html code that
is not supported by Mozilla/Netscape 6, and will never be. Could you please
contact the webmaster to let him know about it?
When/if the page is fixed to be standards-compliant, could you please drop a
comment here saying the page has been fixed?
Thank you a lot,
Fabian.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Comment 3

18 years ago
The bug is not is not in Mozilla, but in the page itself. Thus marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
Actually, this should be reopened. The evangelism component is for bugs 
like these. We let the webmaster know about the problem and ask them 
to fix it. Reopening.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

18 years ago
This web site uses the JavaScript code (ps.js) to create a set of

* DIV elements

When mouse over the handlers (text menu) the JavaScript function changeLayer is
called (ps.js).

Currently changeLayer supports NS4 and IE. It's not a complex page. It basically
changes visibility.

Suggestions:

* They should use the Ultimate Client Sniffer:
http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html

* to create an additional statement supporting the Standards:

For example pieces of code like: (today)

     if (NS4) {
        document.layer1.visibility = "hide";
          document.layer2.visibility = "hide";
          document.layer3.visibility = "hide";
          document.layer4.visibility = "hide";
          document.layer5.visibility = "hide";
        }
          if (IE4) {
        document.all.layer1.style.visibility = "hidden";
          document.all.layer2.style.visibility = "hidden";
          document.all.layer3.style.visibility = "hidden";
          document.all.layer4.style.visibility = "hidden";
          document.all.layer5.style.visibility = "hidden";
        }

should be more like:

     if (is_nav4up) {
        document.layer1.visibility = "hide";
          document.layer2.visibility = "hide";
          document.layer3.visibility = "hide";
          document.layer4.visibility = "hide";
          document.layer5.visibility = "hide";
        }
          if (is_ie4up) {
        document.all.layer1.style.visibility = "hidden";
          document.all.layer2.style.visibility = "hidden";
          document.all.layer3.style.visibility = "hidden";
          document.all.layer4.style.visibility = "hidden";
          document.all.layer5.style.visibility = "hidden";
        }
        if(is_gecko) {

	document.getElementById("layer1").style.visibility="hidden";

	document.getElementById("layer2").style.visibility="hidden";

	document.getElementById("layer3").style.visibility="hidden";

	document.getElementById("layer4").style.visibility="hidden";

	document.getElementById("layer5").style.visibility="hidden";

	}

----

Comment 6

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
Status: REOPENED → NEW

Updated

18 years ago
Priority: -- → P4

Comment 7

17 years ago
-> Intl
Assignee: bclary → nitot
QA Contact: zach → momoi

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Updated

17 years ago
Whiteboard: CentralEurope
(Assignee)

Comment 8

17 years ago
-> CentralEurope
Assignee: nitot → piskozub
Component: European → Central Europe
QA Contact: momoi → pali
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

17 years ago
Thanks /\/\arcio. Using your comment I created a corrected ps.js file that works
with the page. I'll attach it to the page and send notce to the webadmin.

I have no idea how I did that with no JavaScript coding experience ;-) Well, C++
and FORTRAN helped a little. I also used Mozilla detection from this very good
page: http://www.the-cool-place.co.uk/javascript/tutorial/javascript1.html
(Assignee)

Comment 10

17 years ago
Created attachment 51271 [details]
The corrected ps.js which works with Mozilla
(Assignee)

Comment 11

17 years ago
Created attachment 51273 [details]
Corrected version of ps.js (the ball is better placed)
(Assignee)

Updated

17 years ago
Attachment #51271 - Attachment is obsolete: true
(Assignee)

Comment 12

17 years ago
The page author has been contacted.
(Assignee)

Updated

17 years ago
Summary: [LAYER] java script does not work → [LAYER] java script does not work (www.tuniv.szczecin.pl)
http://www.ps.pl/index1.html is fixed, though we are terribly slow on that page
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

17 years ago
Verifying fixed. 

BTYW, the page is slow IMHO due to low bandwith, not Mozilla fault.
Status: RESOLVED → VERIFIED

Comment 15

16 years ago
tech evang june 2003 reorg
Component: Europe: Central → Polish
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.