In private mode, one (only one!) window FireFox closes without tabs-warning, even if warning is enabled

RESOLVED DUPLICATE of bug 502307

Status

()

RESOLVED DUPLICATE of bug 502307
8 years ago
8 years ago

People

(Reporter: c56d7x, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; ru; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14 WebMoney Advisor
Build Identifier: 3.6.14

In private mode, one (only one) window FireFox closes without tabs-warning ("You try to close several (x) tabs. Are you sure you want to continue?"), even if warning is enabled (browser.tabs.warnOnClose;true). If you open several windows FireFox, then this problem does not exist (warning appears successful).

Reproducible: Always

Steps to Reproduce:
1. Launch FireFox in private mode or enable always private mode.
2. Open several tabs in one (!) window.
3. Try to close FireFox Window.
Actual Results:  
FireFox closes without tabs-warning

Expected Results:  
FireFox should show a warning: "You try to close several (x) tabs. Are you sure you want to continue?"

If you open several windows Firefox and several tabs, warning appears successful when you try to close one of opened windows FireFox.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 502307
(Reporter)

Comment 2

8 years ago
bug 502307 Reported: 2009-07-03
Why this bug is not fixed?
You need to log in before you can comment on or make changes to this bug.