Closed Bug 638747 Opened 10 years ago Closed 10 years ago

netscape.javascript.JSException: JavaScript error while getting property "document"

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 629030

People

(Reporter: x2, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14

Displaying and/or refreshing a page with *any* applet triggers above error.
A few refreshes may be required.
Happens only w Firefox/3.6.14 (on XP, Win7, and Linux).
The applet in x.htm contains no code at all.
X.java source and complete trace dump is included in x.htm.

Reproducible: Always

Steps to Reproduce:
1. Display http://OmnipotenceSoftware.com/x.htm w Firefox/3.6.14
2. Refresh a few times
3. See JAVA console for crash
Actual Results:  
netscape.javascript.JSException: JavaScript error while getting property "document"
	at sun.plugin2.main.client.MessagePassingJSObject.newJSException(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.waitForReply(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.doMemberOp(Unknown Source)
	at sun.plugin2.main.client.MessagePassingJSObject.getMember(Unknown Source)
	at sun.plugin2.main.client.MessagePassingExecutionContext.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getDocumentBase(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.getCodeBase(Unknown Source)
	at sun.plugin2.applet.Applet2Manager.verifyJarVersions(Unknown Source)
	at sun.plugin2.applet.Applet2Manager.getClassLoaderCacheEntry(Unknown Source)
	at sun.plugin2.applet.Applet2Manager.getAppletAppContext(Unknown Source)
	at sun.plugin2.main.client.PluginMain.handleMessageStartApplet(Unknown Source)
	at sun.plugin2.main.client.PluginMain.mainLoop(Unknown Source)
	at sun.plugin2.main.client.PluginMain.run(Unknown Source)
	at sun.plugin2.main.client.PluginMain.main(Unknown Source)

Expected Results:  
no crash !

call me if u like at 423-745-0026
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629030
You need to log in before you can comment on or make changes to this bug.