Closed Bug 638755 Opened 9 years ago Closed 9 years ago

Disallow --disable-ipc

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: Mitch)

References

Details

(Whiteboard: fixed-in-bs)

Attachments

(1 file)

Now that we can require libxul, we can also require IPC, and this will make code maintenance a lot simpler as we work on content proceses for Firefox. Ted says Mitch would happily take this bug ;-)

Bug 638429 (disallow --disable-libxul) needs to land first.

I don't really care if we clean up the MOZ_IPC ifdefs immediately, I can do that later as necessary.
Does IPC work (or at least build and not crash) on weird platforms?  In other words, can OS/2 build with --enable-ipc?
I don't know, but I wish to require it anyway. OS/2 would need to adjust their code so that it does work. It is the basis for most of what we are doing moving forward.
Just to clarify: I assume this is going to mozilla-central, not mozilla-2.0. Right now TenFourFox doesn't support --enable-ipc either.
Attached patch PatchSplinter Review
Attachment #516880 - Flags: review?(ted.mielczarek)
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Attachment #516880 - Flags: review?(ted.mielczarek) → review+
Blocks: 639754
http://hg.mozilla.org/mozilla-central/rev/f1b4371344d9
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Blocks: 644093
Depends on: 536262
Blocks: 659940
No longer blocks: 659940
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.