Closed Bug 638763 Opened 9 years ago Closed 9 years ago

Firefox sends text as images to the printer when hardware acceleration is enabled

Categories

(Core :: Printing: Output, defect, major)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 638764

People

(Reporter: Er.Thirumalai, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

When printing text files with PDF Creators like Adobe pdf, Foxit Phantom & nitro pdf the text in output PDF is not selectable or editable.
That means Firefox sends the text as images to the printer.

Reproducible: Always



Expected Results:  
The text Should be selectable
On which particular pages?
(In reply to comment #1)
> On which particular pages?

In all Pages.
Build identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0


I am using Firefox 4 rc build 1.

It appears with all Firefox 4 betas.

I am not sure with Firefox 3
Hmm.  Does it still happen if you turn off hardware acceleration?
Version: unspecified → Trunk
No, I have checked it. Without Hardware acceleration It prints as Text.
What is the Problem with hardware acceleration settings?
Bas?

Presumably the fact that we don't have the text ourselves in this case, since it's being composited on the GPU and all we have is the bitmap the GPU produces?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox send Texts as the Images to the printer → Firefox sends text as images to the printer when hardware acceleration is enabled
This is probably something to do with the way we handle D2D font rendering to non-D2D surfaces.
(In reply to comment #7)
> This is probably something to do with the way we handle D2D font rendering to
> non-D2D surfaces.

There's a path for GDI surface, otherwise cairo will get masks for the glyphs and composite things itself.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638764
You need to log in before you can comment on or make changes to this bug.