Closed Bug 638770 Opened 10 years ago Closed 9 years ago

clicking on a quicktime video pauses it

Categories

(Plugins Graveyard :: QuickTime (Apple), defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: AlexLakatos, Unassigned)

Details

(Whiteboard: [4rc][fx6])

Clicking on a quicktime video pauses it, but clicking it a second time does not play it. Also the play/pause button does not change state.

Steps To Reproduce
1.Go to http://trailers.apple.com/trailers/paramount/rango/
2.Play a trailer
3.Press on the playing movie

Actual Results
3.The movie pauses, but the play/pause button does not change state

Expected Results
3.Nothing happens, the movie keeps playing
Whiteboard: [4rc]
Able to reproduce with 

Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0 

Plugin Version: 7.6.9.0
I can reproduce this. Clicking on the video area pauses the video, clicking again doesn't resume the video. Double-clicking does resume the video. Toggling the video control pause/play will also resume the video playback.

Fx3.6.15, and Fx4b12 behave the same way.
I tested this using Mac, and was not able to reproduce, so may be Windows only.
I think it would be nice if clicking a second time resumed the video playback, or if clicking the pause/play button resumed it (as opposed to having to toggle it), but it doesn't seem like a problem.

Also, IE8 has the same issue.
(In reply to comment #3)
> I tested this using Mac, and was not able to reproduce, so may be Windows only.

This is a Windows only issue, on MacOS X 10.6 and Ubuntu 10.4 nothing happens when I click on a Quicktime video.
Able to reproduce this on both Firefox 3.6.15 and 4 RC
Reproducible on 
Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0
Whiteboard: [4rc] → [4rc][fx6]
Still an issue on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0.
Tested with QuickTime Plug-in 7.7.1 7.7.1.0
Can you try this in other browsers? Is this a Firefox bug or a plug-in bug?
The issue is reproducible on Opera and IE9. On Chrome and Safari clicking on the video screen doesn't pause at all the video. I think it's a plugin issue.
Thanks Anthony.
Another key thing to point out here is the Chrome and Safari are both Webkit; so it would appear this could be a Webkit issue. FWIW, I personally think clicking on a video should pause it.
Component: Plug-ins → QuickTime (Apple)
Product: Core → Plugins
QA Contact: plugins → apple-quicktime
Version: Trunk → unspecified
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #11)
> Another key thing to point out here is the Chrome and Safari are both
> Webkit; so it would appear this could be a Webkit issue. FWIW, I personally
> think clicking on a video should pause it.

Indeed, though the video does not resume after clicking it again. To resume the video, one must select the pause button twice (once to change its state to a Play button and the second time to play it properly)
I'm inclined to say this is INVALID as this is how the Quicktime desktop application behaves as well. I assert this is likely a UX issue with Quicktime and not with Firefox. Please reopen if you feel this is something we can/should fix in Firefox.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.