java.net.MalformedURLException: no protocol: error from second loading of applet

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
critical
RESOLVED WONTFIX
7 years ago
7 months ago

People

(Reporter: Jonathan Stevens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110218 Firefox/3.6.14

Upon second loading of a java applet there is a malformed URL exception despite the fact that the applet started the first time. the URL path is local but Java cannot find the applet upon a second time loading:

java.net.MalformedURLException: no protocol: at java.net.URL.<init>(Unknown Source) at java.net.URL.<init>(Unknown Source) at <applet name>
sun.plugin2.applet.Plugin2Manager.setupGrayBoxPainter(Unknown Source) at sun.plugin2.applet.Plugin2Manager.access$500(Unknown Source) at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source) at java.lang.Thread.run(Unknown Source) java.net.MalformedURLException: no protocol: wbapplet.jar at java.net.URL.<init>(Unknown Source) at java.net.URL.<init>(Unknown Source) at sun.plugin.util.GrayBoxPainter.setProgressFilter(Unknown Source) at sun.plugin2.applet.Plugin2Manager.setupGrayBoxPainter(Unknown Source) at sun.plugin2.applet.Plugin2Manager.access$500(Unknown Source) at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source) at java.lang.Thread.run(Unknown Source) exception: name. java.lang.IllegalArgumentException: name at sun.plugin2.applet.Applet2ClassLoader.addJar(Unknown Source) at sun.plugin2.applet.Applet2Manager.loadJarFiles(Unknown Source) at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Exception: java.lang.IllegalArgumentException: name 

Reproducible: Always

Steps to Reproduce:
1. Load a webpage with a Java applet
2. open the console when the page does not start
3. Notice the URL exception
Actual Results:  
No webpage loads

Expected Results:  
Web page loads

Updated

7 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Why is this marked security sensitive?  It probably isn't.

And it appears to be just a dup of bug 629030.
Did this go away in Firefox 3.6.15? If so then it's definitely a dupe of bug 629030.
Group: core-security
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.