Fix broken links to old release notes file.

RESOLVED WONTFIX

Status

()

Bugzilla
bugzilla.org
RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
>     ----- Forwarded Message ----
>     *From:* Allen Ruminski <allen.ruminski@gmail.com>
>     *To:* webmaster@mozilla.org
>     *Sent:* Thu, February 17, 2011 9:59:26 PM
>     *Subject:* [webmaster] broken link
> 
>     Hello,
>     I have a Bugzilla 2.20 installation that I wish to upgrade to 4.0.
>     At the bottom of
>     http://www.bugzilla.org/releases/4.0/release-notes.html#v40_previous
>     there is a hyperlink called "Release Notes For Bugzilla 2.22 and
>     Earlier" that is broken. Please fix so that I may have the guidance
>     I need to upgrade to 4.0.

This link is broken an all the release notes back to 3.0. It's actually found at $BUGZILLA_HOME/docs/en/rel_notes.txt. Perhaps we could link to a copy on bzr.mozilla.org or something?

Gerv

Comment 1

7 years ago
Sure, the thing to patch would be bin/do-release.pl in the bugzilla www repo.
(Reporter)

Comment 2

7 years ago
Max: you mean get that script to hack the release notes to change the URL before writing them to disk on the website?

Surely this file is never going to change again, and the easiest thing would be to edit pages/release-notes.html.tmpl and change the URL in there to:

http://bzr.mozilla.org/bugzilla/trunk/annotate/head:/docs/en/rel_notes.txt

or

http://bzr.mozilla.org/bugzilla/trunk/download/head:/rel_notes.txt-20080404000536-q652ye0jg2i1-5/rel_notes.txt

or something like that?

Gerv

Comment 3

7 years ago
(In reply to comment #2)
> Max: you mean get that script to hack the release notes to change the URL
> before writing them to disk on the website?

  Yeah, that is what I meant.

> Surely this file is never going to change again, and the easiest thing would be
> to edit pages/release-notes.html.tmpl and change the URL in there to:
> [snip]

  The URL in pages/release-notes.html.tmpl should be correct; it's based on docs_urlbase. The bin/do-release script takes that page, as rendered in a Bugzilla installation, and hacks it up to fit on bugzilla.org, which doesn't quite work with docs_urlbase.

  If the link also doesn't work inside of a normal Bugzilla installation, then we should do something about that in pages/release-notes.html.tmpl by making it link to the correct copy inside of that Bugzilla.

Updated

6 years ago
Duplicate of this bug: 671956

Comment 5

3 years ago
Release notes to old versions are no longer provided with bug 883719.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.