News hangs downloading (expired?) articles

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Fairly often (but not reliably reproducible), news hangs (throbber and status
bar animations continue) while downloading messages on news1.sympatico.ca.  It
happens most often when an article that's been expired is requested, but also
happens on other valid articles.  A partial NNTP log is included here:

1024[80587e8]: Sending: GROUP alt.fan.harlan-ellison
1024[80587e8]: Next state: NNTP_RESPONSE
1024[80587e8]: Receiving: 211 25 24506 24540 alt.fan.harlan-ellison
1024[80587e8]: Next state: NNTP_SEND_GROUP_FOR_ARTICLE_RESPONSE
1024[80587e8]: Next state: NNTP_SEND_ARTICLE_NUMBER
1024[80587e8]: Sending: ARTICLE 24526

After 10 minutes or so, I got:

1024[80587e8]: Next state: NEWS_FREE

Neither the message or an error is displayed during this time, and the message
pane is "frozen" (i.e. it does not paint itself, just keeps the contents of any
other windows that have been over it).  I can navigate in the folder and thread
panes, though.

Navigating to another (expired) message, I get:

1024[80587e8]: Next state: SEND_FIRST_NNTP_COMMAND
1024[80587e8]: Next state: NNTP_SEND_GROUP_FOR_ARTICLE
1024[80587e8]: Sending: GROUP alt.fan.harlan-ellison
1024[80587e8]: Next state: NNTP_RESPONSE
1024[80587e8]: Receiving: 211 11 24528 24540 alt.fan.harlan-ellison
1024[80587e8]: Next state: NNTP_SEND_GROUP_FOR_ARTICLE_RESPONSE
1024[80587e8]: Next state: NNTP_SEND_ARTICLE_NUMBER
1024[80587e8]: Sending: ARTICLE 24523
1024[80587e8]: Next state: NNTP_RESPONSE
1024[80587e8]: Receiving: 423 No Such Article In Group
1024[80587e8]: Next state: SEND_FIRST_NNTP_COMMAND_RESPONSE
1024[80587e8]: Next state: NNTP_ERROR
1024[80587e8]: Next state: NEWS_FREE

Sometimes I can navigate away from an unexpired message, then select it again
and it will be retrieved.  Other times it will remain unavailable for the
session or across sessions.

I always get a 423 return code if I try to view the expired articles myself, as
with the second (successful) log excerpt above:

> telnet news1.sympatico.ca 119
Trying 206.172.150.50...
Connected to news1.sympatico.ca.
Escape character is '^]'.
200 Bell Nexxia News Server -- news://news1.sympatico.ca/ (Typhoon v1.2.2)
GROUP alt.fan.harlan-ellison
211 11 24528 24540 alt.fan.harlan-ellison
ARTICLE 24526
423 No Such Article In Group
QUIT
205 GoodBye
Connection closed by foreign host.
(Reporter)

Comment 1

18 years ago
Linux build 2000122710.  Also, I don't have this problem at all reading
news.mozilla.org.

Updated

18 years ago
QA Contact: esther → stephend
Is this an especially slow server?  
(Reporter)

Comment 3

18 years ago
It doesn't seem to be--how would I go about measuring the speed?

The Ellison group doesn't have any particularly large posts, so it shouldn't be
timing out while retrieving them.
There doesn't seem to be anything out of the ordinary with your setup, so I can
only assume there is some kind of underlying network issue here.  I'll try it
with that newsgroup on my P133 and see if I get any results.
Hrm, strange, this works fine for me (there was only 26 postings when I loaded
this ng).  I used RedHat 7, build 2001011208.
(Reporter)

Comment 6

18 years ago
Sounds like it may be the Sympatico server, then.  Any suggestions on debugging?
Not sure how much David or Seth know about Typhoon servers.  Adding David to the
list.  Are you on dialup?  What is the last build you tried this with? 
(Reporter)

Comment 8

18 years ago
I'm running 2001013108 on "high-speed" DSL.  I haven't seen the problem as much
recently (since the "only one download thread for news" bug was fixed), but it
still occurs occasionally.  There hasn't been as much traffic in the group
recently though, and I'm not really subscribed to much else on that server--I'll
try a couple of higher-traffic ng's and see if I see it more.
Okay, if you find an especially high traffic newsgroup, please post it here. 
They are very useful for stress testing!
(Reporter)

Comment 10

18 years ago
Trying with a 500-message set of rec.arts.sf.tv.babylon5.moderated in build
2001020908, I've gotten a few "freezes", but they have gone away after selecting
one or two messages, then returning to the "frozen" message.  I've read about
250 messages and I'd say I've frozen on 15 of those; three occurred in a row,
and the rest have been single occurrences.  The freezes occurred, about 95% of
the time, after I went back to a post I had already read (to see some thread
context that wasn't quoted), then continued to the 'next unread'.

Regarding the comment on the server being slow, I got about 1.5K/s downloading
the list of newsgroups (on a 128K DSL connection).  So I guess that's slow. :-)
 http://www.sympaticousers.org/ has some discussion of the poor news servers,
but nothing specifically about performance.
Wow, hey Seth, take a look at this,
http://www.sympaticousers.org/action/news_service.htm
Looks like they have lots of issues with headers not being downloaded, etc.
(Reporter)

Comment 12

18 years ago
Hmm, I must be reading that page differently.  I thought it referred mostly to
headers (and messages) not being synchronized between the different servers...
although they do mention Netscape (I assume 4.x) having problems with
out-of-order headers.  I haven't seen any problems doing a header download when
entering the newsgroups.
Oh, I haven't read the whole article (yet).  I'm referring to the screenshots, 
where it shows "Warnings" next to Downloading news articles and "Failed" 
checking (what I assume to be) "Bell" a server for new messages.  Notice, there 
don't seem to be any updated warning for this year, though it seems they've had 
their share of problems.

Comment 15

18 years ago
mozilla hangs sometimes/often when using leafnode as newsserver

i think this bug is related to 63880 (or perhaps 58247)

unfortunately it works if I connect directly to the news server (not using leafnode)
and mozilla doesn't always hang if using leafnode. It only hangs on some groups
but if it hangs it will always do.

tried moving the msf file as described in bug 58247
but it still happened (the file was empty btw)

unfortunately i don't know anything about the nntp protocol
but i think mozilla is requesting the article with id 1
that doesn't exist on the server (doesn't exist in the leafnode spool directory)
and perhaps this is the problem ?

so i would say this is bug 63880 ?

i coppied a news message (2) to 1 => now the requested message 1 exists => it works
(unfortunately it seems mozilla doesn't know how many messages there are now but
this is not related to this bug i think.)

the problem doesn't occur with mozilla 0.8.0
or other nntp clients (pine/netscape, navigator 4.7?)

another idea: perhaps it is a problem with "remove all expired articles"


If mozilla hangs there is no network traffic and send and receive buffers are empty.
Leafnode is waiting for incoming traffic.

if you want i can add a lot of detail
(gdb stacktrace , traffic sniffed, netstat, ...)

My system details:My system:
debian gnu/linux 2.2 potato (infofficial x 4.0.2 packages for potato)
linux 2.4.2
mozilla 0.9
leafnode 1.9.9

jens@quark:/etc > ldd /usr/local/mozilla/mozilla-bin
	libgkgfx.so => not found
	libxpcom.so => not found
	libmozjs.so => not found
	libjsj.so => not found
	libplds4.so => /usr/lib/libplds4.so (0x40020000)
	libplc4.so => /usr/lib/libplc4.so (0x40024000)
	libnspr4.so => /usr/lib/libnspr4.so (0x40029000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x4006b000)
	libdl.so.2 => /lib/libdl.so.2 (0x4007e000)
	libc.so.6 => /lib/libc.so.6 (0x40083000)
	libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0x40160000)
	libm.so.6 => /lib/libm.so.6 (0x401a2000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

lib/ld-linux.so.2 -> ld-2.1.3.so
lib/libc.so.6 -> libc-2.1.3.so
lib/libdl.so.2 -> libdl-2.1.3.so
lib/libm.so.6 -> libm-2.1.3.so
lib/libpthread.so.0 -> libpthread-0.8.so
usr/lib/libstdc++-libc6.1-1.so.2 -> libstdc++-2-libc6.1-1-2.9.0.so

Comment 16

18 years ago
Created attachment 34354 [details]
debugging information (stacktrace, netstat, traffic sniffed)

Comment 17

18 years ago
I reported the problem with leafnode. Since mozilla 0.9.3 it seems to be fixed?
Peter Janes, is this bug gone for you too, now?
(Reporter)

Comment 19

18 years ago
I've only noticed "hangs" once or twice in the last month, and they're
attributable to outside influences, so I'd say it's fixed.
Okay, marking as such.  One of you guys please verify then (I'm not running a
leafnode server, currently).  Thanks.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
verified.  Two people's word is good enough for me (especially since Peter was 
the reporter).
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.