URLs from external apps get %-escaped and broken

VERIFIED INVALID

Status

--
blocker
VERIFIED INVALID
8 years ago
7 years ago

People

(Reporter: bugzilla-graveyard, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
STR:

1) Click a link like http://teamcoco.com/content/apple-employees-can't-help-but-gloat-about-new-ipad in Adium, Colloquy, or etc.

AR: 404 page.

ER: Loads http://teamcoco.com/content/apple-employees-can't-help-but-gloat-about-new-ipad .

Compare to clicking the link above, which works fine and doesn't get %-escaped.
(Reporter)

Comment 1

8 years ago
Er, actually, that's broken too. But the link on the http://teamcoco.com home page works. It's possible this is a TE problem (site bug).
(Reporter)

Comment 2

8 years ago
Blah. Never mind. This is because they used a smart apostrophe in the URL and other apps are dumb-ifying the apostrophe. So this could be a TE bug if someone really cared (they shouldn't be using anything but Least Common Denominator characters in links) but it's probably just INVALID.

http://teamcoco.com/content/apple-employees-can’t-help-gloat-about-new-ipad is the actual URL of the page, and that link should work fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.