www.bordersrewardsperks.com - Form On Page Will Not Submit

VERIFIED FIXED

Status

defect
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: alan.perry, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

When I fill in the user name and password on the referenced page, I can't get the form to submit.  This only started happening with 4.0b12.

Reproducible: Always

Steps to Reproduce:
1. Enter user name and password.
2. Press enter or click on submit.
3. Nothing seems to happen.
Actual Results:  
Nothing seems to happen, the submit of the form does not seem to work.

Expected Results:  
It should log you in and bring you to "http://www.bordersrewardsperks.com/overwhelmingoffer/home".

I have tested this in IE 8, and the latest Safari, and Google Chrome, and it works in all of those.  Also, like stated above, this only started occurring when I installed 4.0b12.
Reporter

Comment 1

8 years ago
Also, I ran this in Firefox Safe Mode.  Same result.
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre ID:20110303122446

Last good nightly: 2010-09-10 
First bad nightly: 2010-09-11

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=79d0beec27b5&tochange=73ab2c3c5ad9

Errors in console...

Error: Object.extend is not a function
Source File: https://www.bordersrewardsperks.com/cache/script/id/script_1f97dbebf8329b2a3a0649b22ac9e018d7fc85eb
Line: 35

Error: Event.observe is not a function
Source File: https://www.bordersrewardsperks.com/login/
Line: 1773

Error: $ is not defined
Source File: https://www.bordersrewardsperks.com/login/
Line: 1193

Error: $ is not defined
Source File: https://www.bordersrewardsperks.com/login/
Line: 1364

Might just be evang, but moving to Core::JS for now for someone else to make the call.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
There aren't any js engine changes in that range.... could you double-check that please?

Comment 4

8 years ago
Given the regression window, I'm guessing bug 561636.

If you click "No, my existing account does not have a password"
it reveals two more <input>s that also have required="Yes".
They are inside a display:none ancestor <div> at first.
http://www.whatwg.org/specs/web-apps/current-work/multipage/common-input-element-attributes.html#the-required-attribute
doesn't say anything about styling so I guess they are still required
even when not rendered.  	

-> TE
Assignee: general → english-us
Component: JavaScript Engine → English US
OS: Windows 7 → All
Product: Core → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
Summary: Form On Page Will Not Submit → www.bordersrewardsperks.com - Form On Page Will Not Submit
Version: Trunk → unspecified
> I guess they are still required even when not rendered.      

At the moment, yes.
(In reply to comment #3)
> There aren't any js engine changes in that range.... could you double-check
> that please?

Double checked and regression range is correct, supporting conclusion in comment 4.
Marking this bug blocking bug 561636 so we keep track of broken websites due to hidden invalid form controls.
Blocks: 561636

Comment 8

8 years ago
Website URL mentioned in the bug no longer works. Also, sign-in to site works perfectly in nightly builds.
Thanks for the update :-)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reporter

Updated

8 years ago
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.