Open Bug 638964 Opened 9 years ago Updated 4 years ago

Allow customization of formatting toolbar in Mail Composition

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(Not tracked)

ASSIGNED

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

At the moment the formatting toolbar in the mail composition window is not customisable.

This first patch does some preparation work by:
1/ moving those elements that are not toolbarbuttons into toolbaritems.
2/ moving from using the toolbar id to apply the style to the elements to using a class.
Attachment #517031 - Flags: ui-review?(clarkbw)
Attachment #517031 - Flags: review?(bwinton)
Comment on attachment 517031 [details] [diff] [review]
Toolbaritems and style changes patch v1.0

Looks pretty good to me on initial review.  And in general the concept sounds fine.
Attachment #517031 - Flags: ui-review?(clarkbw) → ui-review+
Attachment #517031 - Flags: review?(bwinton) → review?(bugzilla)
Comment on attachment 517031 [details] [diff] [review]
Toolbaritems and style changes patch v1.0

Unfortunately this has suffered some bitrot so I can't test it. Could you attach a fresh patch? Thanks
Attachment #517031 - Flags: review?(bugzilla)
Unbitrotted, carrying forward ui-r+

(I probably bitrotted myself)
Attachment #517031 - Attachment is obsolete: true
Attachment #521787 - Flags: ui-review+
Attachment #521787 - Flags: review?(bugzilla)
Attachment #521787 - Flags: review?(bugzilla) → review+
Comment on attachment 521787 [details] [diff] [review]
Toolbaritems and style changes patch v1.0a [Checked in: Comment 4]

http://hg.mozilla.org/comm-central/rev/192dd0ddf4a5
Attachment #521787 - Attachment description: Toolbaritems and style changes patch v1.0a → Toolbaritems and style changes patch v1.0a [Checked in: Comment 4]
Why isn't this bug closed fixed ?
(In reply to comment #5)
> Why isn't this bug closed fixed ?

Because you can't yet customise the toolbar - it only did the first round of style changes so far.
Duplicate of this bug: 685649
You need to log in before you can comment on or make changes to this bug.