Element conflicts with too many things. Per the name of the file, let's call it Widget instead.
Change of plans: New class tree will be: Element | Widget (was HtmlXulElement) | [all controls, horizontally] After some investigation, we've decided that broad differences between HTML and XUL widgets are minor and don't merit an entire second class tree. Originally, we were actually just going to combine Element and Widget as well, but Element will be the main merge point between A-Team's work and ours, so we decided to go ahead and keep them separate for the time being.
Summary: Change Element nomenclature to Widget → Change naming of Widget class tree per discussion with A-Team
Fixed with patch in Bug 638967
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.