Closed Bug 63902 Opened 24 years ago Closed 24 years ago

character from a character set was display using fonts in another charactset after converted to unicode

Categories

(Core :: Internationalization, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 60328

People

(Reporter: hingwah, Assigned: erik)

Details

Build ID:Mozilla/5.0 (X11; U; Linux 2.2.18pre21 i686; en-US; m18) Gecko/20001225.
I find that : When the page is specified with illegal lang attribute (e.g <html
lang=dfsdfkhs> or the fonts in alt attribute " <img src alt="sdfkjh"> or
if the fonts of the specified language is not specified.
The page with Tradition Chinese language using character set big5 is displayed
using the fonts -*-*-*-*-*-*-*-*-*-*-jisx0208.1983-0 instead of
-*-*-*-*-*-*-*-*-big5-0 .Mozilla is able to detect that it is big5 code
,however it display using another charset fonts.
It seem that the characters in big5-0 and jisx0208.1983-0 have the same ID in
unicode-set
When mozilla first convert the characters to unicode. It don't remember
what the charaset the fonts use. When it find that the system don't have
the unicode fonts. It just try to find a fonts from any charaset that can
display the font,instead of using the original charset.
In general,it will arise when same word have different coding in 2 different
chracter set, but is unique in the unicode
.e.g a word 0x3126 in jisx0208.1983-0 and  0xa56b in big5 is actually the same word
as the Japanese Font will contain some chinese fonts...
However,mozilla will display it using japanese fonts instead........
Please see the screenshot in bug #60328, which illustrate the problem:
www.sourceforge.net chinese page :
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=21499
sourceforeg.net page if remove the lang attribute tag :
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=21500
Reassign to erik.
Assignee: nhotta → erik
Pretty sure this is a duplicate of bug 60328.

*** This bug has been marked as a duplicate of 60328 ***
Status: UNCONFIRMED → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.