bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Preferences:Navigator:Smart Browsing:After entering a domain name in the textbox opposite to the Domain field in the What's Related sidebar tab section and pressing the Add button, an extra blank line is added in the list of sites.

VERIFIED INVALID

Status

SeaMonkey
Preferences
P5
normal
VERIFIED INVALID
18 years ago
14 years ago

People

(Reporter: Dipu Joseph, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: 
BuildID:    20001205

Preferences:Navigator:Smart Browsing:After entering a domain name in the 
textbox opposite to the Domain field in the What's Related sidebar tab section 
and pressing the Add button, an extra blank line is added in the list of sites 
just above the name of the given site.

Reproducible: Always
Steps to Reproduce:
1.From Edit menu of the browser, select Preferences. 
Select Navigator->Smart Browsing.
2.Enter a domain name (such as www.123india.com)in the text box opposite to 
'Domain' field in the What's Related sidebar tab section. 3.Then press Add 
button besides the textbox. Close the Preferences window.


Actual Results:  Along with the name of the given site, an extra blank line is 
added in the list of sites just above the name of the given site.

Expected Results:  No extra blank line comes. Only the name of the given site 
is added to the list of sites.

Comment 1

18 years ago
WORKSFORME
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001010211 M18 Trunk Build.

Comment 2

18 years ago
OK now I am seeing this too.

Make sure you enter 2 seperate entries into the Domain Box and then you will see
the problem with the extra line inbetween the two.


Also seen on:
Platform: PC
OS: Windows 2000
Mozilla Build: 2000123122 M18 Trunk Build

The linux version is the same one i said worked for me a second ago. Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All
Hardware: PC → All
I see this too, probably a simple fix. 
Keywords: nsbeta1
nav triage: user impact not clear - reducing to P5. 
Priority: -- → P5

Comment 5

18 years ago
nav triage team:

marking nsbeta1+ for now, unless it's something simple, this most likely will
get minused soon
Whiteboard: nsbeta1+

Comment 6

18 years ago
nav triage team:

Putting on the backburner, removing nsbeta1+, marking future
Whiteboard: nsbeta1+
Target Milestone: --- → Future

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 7

17 years ago
still happening.

-> default owner
Assignee: matt → sgehani

Comment 8

16 years ago
Created attachment 87944 [details] [diff] [review]
Fix for problem

The preference gets added as:

domain.com,

So when it is parsed, there exists a second entry that is blank ("")

Easiest fix is to check for empty entries when going through the for loop to
enumerate the domains.

Updated

16 years ago
Attachment #87944 - Flags: review+

Comment 9

16 years ago
This UI is gone now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.