Fullscreen mode breaks when resized by javascript

RESOLVED DUPLICATE of bug 349637

Status

()

RESOLVED DUPLICATE of bug 349637
8 years ago
8 years ago

People

(Reporter: liznben, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre

When I'm in fullscreen (F11) mode, and I click on the product image in the provided URL to provide a bigger version of the image, firefox comes out of fullscreen and shows nothing but the image - no toolbars, titlebar, tabbar or even window borders.  It looks pretty bad.  To get everything to come back I have to hit F11 3 times - first time it gives you a partial draw of the window, second time it gives a normal fullscreen, then 3rd time back to restored window.

Reproducible: Always

Steps to Reproduce:
1. Go to the url http://www.4sevens.com/product_info.php?cPath=92&products_id=645
2. Hit F11 to go into fullscreen.  (Note: Bug is more obvious if you allow "hide toolbars" for fullscreen mode here, if you haven't already.)
2. Click on the image of the product to enlarge it
Actual Results:  
1. A new tab is opened, focus switches to it, and the image is loaded into it
2. Firefox is resized by website's javascript.
3. All you get is the enlarged image - you don't get any toolbars, titlebar, borders - nada


Expected Results:  
Firefox is resized as required, but it leaves fullscreen and you get normal firefox back.

For a newbie user this would really thrown them off using firefox.
(Reporter)

Comment 1

8 years ago
Created attachment 517128 [details]
Screenshot of what firefox looks like when bug hits

Note for this screenshot, I switched to the bugzilla page and right clicked to bring up the context menu, so you can see that this is really the firefox window.

Comment 2

8 years ago
I can reproduce the above STR if set browser.link.open_newwindow.restriction to 0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110304 Firefox/4.0b13pre ID:20110304030406

The following STR  is enough to reproduce the issue with default config.

[Steps to Reproduce]
1. Start Minefield with new profile
2. Go to fullscreen mode (F11)
3. Enter "javascript:window.resizeTo(600,600);" in Location Bar (without quotations)

[Actual Result]
  There are not windows border and toolbars.(The appearance seems like fullscreen mode)
[Expected Result]
  The appearance should be normal mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Windows Vista → All
Resolution: --- → DUPLICATE
Duplicate of bug: 349637

Comment 3

8 years ago
WORKAROUND: 
Alt > Tools > Options > Content > "Enable JavaScript" Advanced > uncheck "Move or resize existing windows"
(set dom.disable_window_move_resize to false)

Comment 4

8 years ago
Oops
(set dom.disable_window_move_resize to true)
You need to log in before you can comment on or make changes to this bug.