Mails are marked as replied to when the mail is sent to the outbox

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: mozilla-bugs-2011.08, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-10-16])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: 

Mails are marked as replied to when the mail is sent to the outbox, not when the mail is sent to the SMTP server. That means that mails are marked as having been replied to that have not yet been relied to.

Reproducible: Always

Comment 1

8 years ago
hmm. 

how are you determining they were marked as replied to?
or do you mean read vs. unread?
(Reporter)

Comment 2

8 years ago
how are you determining they were marked as replied to?

By the icon that leads the Subject field.

Comment 3

7 years ago
Dotan, in what version are you reporting this?  and can you reproduce with version 7?


WFM with current trunk build.
1. set work offline
2. compose and "send" message

results: message is not marked as replied

3. set work online
results: messages marked as replied

mailnews.sendInBackground both true and false behave the same
Whiteboard: [closeme 2011-10-16]
It probably is a Conversations bug.
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change is in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

7 years ago
When the SMTP server is offline I can reproduce the issue. This is in Thunderbird 7.

Thanks.
Dotan,

Can you reproduce the issue with *conversations off*?

Thanks,

jonathan
(Reporter)

Comment 8

7 years ago
Yes, I test in safe mode.
(Reporter)

Comment 9

7 years ago
I'm sorry, cancel that last comment. I usually test in safe mode but as my SMTP server is intermittently not working and I cannot test at will, it is possible that this bug was not triaged in safe mode.

I have no problem leaving the resolution as INCOMPLETE until I can triage in safe mode and confirm / deny the issue.
(In reply to Dotan Cohen from comment #9)

> I have no problem leaving the resolution as INCOMPLETE until I can triage in
> safe mode and confirm / deny the issue.

Great you can also try to grab a smtp log while you are investigating : see https://wiki.mozilla.org/MailNews:Logging
You need to log in before you can comment on or make changes to this bug.