extensions.checkCompatibility has no effect

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Spencer Hakim, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4rc])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

In the Firefox 4 RC1, extensions.checkCompatibility seems to have no effect anymore. This is the case both with and without the Add-on Compatibility Reporter extension installed. Tested with both new and old profiles on both Win7 and OS X.

Reproducible: Always

Steps to Reproduce:
1. Set extensions.checkCompatibility to false in about:config
2. Restart Firefox
3. Attempt to install incompatible addon or open addon manager to view previously installed incompatible addons
Actual Results:  
Incompatible addons are still disabled.

Expected Results:  
Incompatible addons will still load (or at least attempt to)
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Whiteboard: [4rc]
This is by design. The preference was changed. See the link below. You'd need to use extensions.checkCompatibility.4.0 for the RC.
http://kb.mozillazine.org/Extensions.checkCompatibility
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.