No option to paste preformatted text in a plain-text email

RESOLVED DUPLICATE of bug 475712

Status

RESOLVED DUPLICATE of bug 475712
8 years ago
8 years ago

People

(Reporter: josh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When composing a plain-text email, the option to paste preformatted text does not seem to exist.  Pasting text with significant line endings, such as code or a patch, will word-wrap that text, mangling it.  Several guides for sending code or patches through Thunderbird[1] suggest turning word-wrap off by changing the word-wrap column to 0.  However, this prevents wrapping on the remainder of the mail causes a different problem, namely that lines elsewhere in the mail will not get wrapped.  And finally, if the user uses the HTML composer so that the preformatted text option works, and then hopes that Thunderbird sends plain-text email, they risk sending HTML mail to a technical mailing list, giving them a *third* way to look like an idiot. :)

[1] See, for instance, Documentation/email-clients.txt in the Linux kernel, Documentation/SubmittingPatches in git, or various writeups found by searching for "thunderbird inline patch".  The existence of such guides in the first place confirms that a problem exists.


I did a quick search for an example of this bug causing real problems, and it didn't take long to turn up http://thread.gmane.org/gmane.linux.kernel/1084105/focus=3263 , from as recent as January of this year.  The original mailed patch got corrupted by both this bug and bug 204478.  The patch author re-sent the patch by following the Linux kernel's Documentation/email-clients.txt guide, which among other things says to turn off word-wrap.  The patch then applied, but the non-patch text in the email had excessively long lines rather than the conventional 72 characters or so.

As far as I can tell, no way currently exists for someone to use Thunderbird to send a plain-text mail with undamaged code, properly word-wrapped non-code text, and no possibility of HTML.  That's a pretty common use case for developers, and I can vouch for the appearance of threads like the one mentioned above quite frequently.
(Reporter)

Comment 1

8 years ago
In writing that, I just realized that in addition to not having an option to *paste* preformatted text, there is also no option to *compose* preformatted text, to allow typing lines longer than the current word-wrap limit.

Comment 2

8 years ago
Pasting preformatted text doesn't work is a known issue, thus duping. The 2nd part is possible by temporarily setting mailnews.wraplength to 0 (zero).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475712
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Pasting preformatted text doesn't work is a known issue, thus duping. The 2nd
> part is possible by temporarily setting mailnews.wraplength to 0 (zero).
> 
> *** This bug has been marked as a duplicate of bug 475712 ***

Thanks; I don't know why that bug didn't come up when I searched for existing bugs.  I must not have used the right keywords.

The workaround you describe appears in my original report as well, and I described the problem it causes (excessively long lines for non-preformatted text).
You need to log in before you can comment on or make changes to this bug.