Last Comment Bug 639284 - Metadata of "Provider for Google Calendar" extension are not translated at AMO
: Metadata of "Provider for Google Calendar" extension are not translated at AMO
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: GData (show other bugs)
: unspecified
: All All
-- normal with 1 vote (vote)
: 3.9
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
https://addons.mozilla.org/cs/thunder...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-06 03:33 PST by Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo)
Modified: 2015-01-01 03:19 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (2.22 KB, patch)
2014-12-11 03:30 PST, Philipp Kewisch [:Fallen]
bv1578: review+
Details | Diff | Splinter Review
Fix - v2 (2.58 KB, patch)
2014-12-22 00:54 PST, Philipp Kewisch [:Fallen]
philipp: review+
Details | Diff | Splinter Review

Description User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2011-03-06 03:33:21 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: 

In Czech translation of this addon is it's name translated as "Poskytovatel Google kalendáře". It's confusing for users.

for example:
Somebody recommend this addon to me, but he says only "Poskytovatel Google kalendáře".
But addon "Poskytovatel Google kalendáře" doesn't exist. On AMO you can find it only like "Provider for Google Calendar".

Reproducible: Always
Comment 1 User image Philipp Kewisch [:Fallen] 2011-03-06 03:45:51 PST
This is rather a translation issue, moving to the right component.
Comment 2 User image Pavel Franc - Mozilla.cz 2011-03-06 06:56:44 PST
The extension name and description could be localized via /calendar/chrome/calendar/providers/gdata/gdata.properties
So it is translated in Czech (the same is true also for other locales). It does not make sense to have untranslated Google Calendar extension name for translated service called Google kalendář. 

The real issue here is untranslated extension name, description, etc. at AMO.
https://developer.mozilla.org/en/Localizing_extension_metadata_on_addons.mozilla.org
Comment 3 User image Pavel Franc - Mozilla.cz 2011-03-06 07:02:52 PST
http://mxr.mozilla.org/l10n-central/search?string=a62ef8ec-5fdc-40c2-873c-223b8a6925cc gives the full list of translated names and descriptions that need to be copied into AMO.
Comment 4 User image Philipp Kewisch [:Fallen] 2011-03-06 10:26:52 PST
Oh, now I understand the issue, I'm sorry. I'll add the strings soon.
Comment 5 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2011-07-01 02:52:54 PDT
Four month and still unable to find the addon by localized name.
Comment 6 User image Pavel Franc - Mozilla.cz 2011-07-01 03:39:33 PDT
Philipp, do you need help? Just set me (pfranc@mozilla.cz) as a developer of that addon and I'll fix the translations for you.
Comment 7 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2013-02-04 00:19:31 PST
Almost two years and the add-on page is still not localized...
Comment 8 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2014-07-27 08:28:27 PDT
After so long time, I noticed the AMO page is still in English. Can I help somehow to fix it?
Comment 9 User image Philipp Kewisch [:Fallen] 2014-07-28 03:39:39 PDT
The only issues I have with this is that if I change the strings I'm likely to forget to ask you folks for updates. Anyway, lets give it a try. Could you post the translations in a comment so I can copy/paste them into the AMO translation?
Comment 10 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2014-07-28 12:42:06 PDT
Czech strings are located in the l10n repository https://hg.mozilla.org/releases/l10n/mozilla-beta/cs/ in calendar/chrome/calendar/providers/gdata/gdata.properties file.

Provider for Google Calendar -> Poskytovatel Google kalendáře
Allows bidirectional access to Google Calendar -> Umožňuje obousměrný přístup ke Google kalendáři

The "About this Add-on" text is currently not translated, but we can translate it very quickly.
Comment 11 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2014-11-27 04:07:45 PST
As the current Provider version is in English only https://addons.mozilla.org/cs/thunderbird/addon/provider-for-google-calendar/versions/?page=1#version-1.0.1 , do you plan (when preparing the add-on localization) also to include the AMO website l10n?
Comment 12 User image Philipp Kewisch [:Fallen] 2014-11-27 06:23:27 PST
I plan to get back to a state where the addon will be translated very soon now. I haven't included any website strings yet. I've attempted this a few years ago when I started the Provider, but there was pushback from a few Mozilla folks.

I think its time to revisit that and add the strings. It still won't be automated, but at least they will be available. Maybe I can write a script to auto-upload those strings.
Comment 13 User image internero 2014-12-11 02:30:30 PST
I can help translation to Brazilian Portuguese (pt_BR).
Comment 14 User image Philipp Kewisch [:Fallen] 2014-12-11 03:30:36 PST
Created attachment 8534928 [details] [diff] [review]
Fix - v1

This should take care. The strings will be translatable via standard means, but ignored in the dashboard.
Comment 15 User image Decathlon 2014-12-18 00:51:12 PST
Comment on attachment 8534928 [details] [diff] [review]
Fix - v1

The code seems correct, but it can be verified only when it is on the repositories, or do I miss something?

r+

Philipp, since you are there, could you also correct the typo on line 5 of the filter.py file?
Comment 16 User image Philipp Kewisch [:Fallen] 2014-12-22 00:54:16 PST
Created attachment 8539990 [details] [diff] [review]
Fix - v2

(In reply to Decathlon from comment #15)
> Comment on attachment 8534928 [details] [diff] [review]
> Fix - v1
> 
> The code seems correct, but it can be verified only when it is on the
> repositories, or do I miss something?
Yes, I don't think we could verify this otherwise.

> Philipp, since you are there, could you also correct the typo on line 5 of
> the filter.py file?
Done, thanks!
Comment 17 User image Geoff Lankow (:darktrojan) 2015-01-01 03:19:31 PST
https://hg.mozilla.org/comm-central/rev/4d26b2425cfe

Note You need to log in before you can comment on or make changes to this bug.