Closed Bug 639307 Opened 9 years ago Closed 7 years ago

Defective error message: "Firefox is already running, but is not responding. To open a new window you must first close the existing Firefox process or restart your system"

Categories

(Thunderbird :: Untriaged, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 278860

People

(Reporter: bugs, Unassigned)

Details

(Whiteboard: [dupeme])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110221 Thunderbird/3.1.8

There are several open bug reports concerning this message, and the chief reasons for it are easy to diagnose and fix:

1. Non-existent profile named in profile.ini (e.g. b/c of a typo or folder move).

2. Read-only profile.

3. Lock file (parent.lock on Windows systems)left over from previous program execution.

4. And, finally, the problem this message is actually designed to cover: Thunderbird is already running and is "stuck."  Anecdotally, based on my research, this almost never happens.

The solution seems simple to me: create a more helpful error message, instead of using the current message that usually steers the user in the wrong direction.

One fix might be ti simply refer the user here:
https://support.mozilla.com/mai/kb/Firefox%20is%20already%20running%20but%20is%20not%20responding

Thank you for all of your hard work on Thunderbird.  Truly an awesome product!

Reproducible: Always

Steps to Reproduce:
1. One way: edit profile.ini and munge the path to your profile.  Voila.
2. Run Thunderbird.
Actual Results:  
Message box: "Firefox is already running, but is not responding. To open a new window you must first close the existing Firefox process or restart your system"


Expected Results:  
See above -- error message provides erroneous instructions for this error.
good info. definitely a duplicate (not in thunderbird bugs)
Severity: minor → normal
Whiteboard: [dupeme]
Component: General → Untriaged
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
You need to log in before you can comment on or make changes to this bug.