Closed Bug 639329 Opened 9 years ago Closed 9 years ago

Autocomplete suggestions does not work correctly on orientation changes

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

(Whiteboard: [has patch][has review][needs approval])

Attachments

(1 file)

Attached patch PatchSplinter Review
From https://bugzilla.mozilla.org/show_bug.cgi?id=638552#c6 

This seems fixed in the 20110305 nightly, but I see new issues (see three
attached screenshots):

(1) when panning to the left: suggestions get gut off on the LEFT side - I may
consider that acceptable, as users can simply pan back. But the behavior is
inconsistent: when you pan to the right, you actually shorten the suggestion
field to fit it in the visible content area
(2) Changing screen orientation while suggestions are shown: places suggestions
in wrong positions (should be pointing to input field) - this problem remains
even if you turn back to portrait
(3) Back in portrait mode: now we have TWO issues: the list is (still) in the
wrong place, and it moves into the left panel
Attachment #517271 - Flags: review?(mark.finkle)
Assignee: nobody → 21
tracking-fennec: --- → ?
Whiteboard: [has patch][needs review]
Duplicate of this bug: 639330
Duplicate of this bug: 639331
Duplicate of this bug: 639333
Attachment #517271 - Flags: review?(mark.finkle) → review+
Whiteboard: [has patch][needs review] → [has patch][has review][needs approval]
Blocks: 639341
http://hg.mozilla.org/mobile-browser/rev/102b9ea97880
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
VERIFIED FIXED on: 

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110316 Firefox/4.0b13pre Fennec /4.0b6pre 

Device: Motorola Droid 2 (Android 2.2)
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.