Grey Top-Left-Corner Zombie Square bug

REOPENED
Unassigned

Status

()

REOPENED
8 years ago
5 years ago

People

(Reporter: madamboevarix, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre

A grey square appears keeping itself here & afloat from the start of Firefox, until next restart. Nothing can be done with it, and it's opaque. All the top-left buttons & bars are covered.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox with 1 or 2 windows with 4 or more tabs previously saved.
2.The square appears ! Nothing to to to get rid of it.
3.Restart Firefox : the square disappears.
4.Let's try. Restart Firefox again : The grey square reappears ! 
Actual Results:  
Happens around 50/100 restarts, and maybe 15/100 starts 
Happened since Firefox 4b*…

Expected Results:  
Grey Top-Left-Corner Zombie Square should not appear !

theme default

Comment 1

8 years ago
Screenshot please.

Also, does it happen if you use a clean profile?
http://support.mozilla.com/kb/Basic+Troubleshooting#w_make-a-new-profile

Thanks!
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Created attachment 517563 [details]
Screen capture

Yeah it happens randomly even with a brand new profile, though I must say I got some 10 addons installed (all stable)
(Reporter)

Comment 3

8 years ago
Created attachment 517564 [details]
Screen capture

As you can see it's afloat, masking mail too.

Comment 4

8 years ago
If you have 10 addons installed, it isn't a clean profile.

Please can you see if it occurs with a new profile that has not had any addons installed. If that works fine, then one of the addons is likely at fault; disabling them one by one will help you work out which.

Thanks!

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 5

7 years ago
I am reproducing this bug with the following steps:

1) With greasemonkey, install a userscript like Google + Enhancer. http://userscripts.org/scripts/show/106067

2) Get your cookies into a state where you're logged into some Google services but not others (which is really easy if you use two-factor auth)

3) You'll start to randomly get HTTPAuth popups for passwords for google services as the userscript pulls from various feeds and needs a password.

4) Click cancel on the popup.  (I'm not sure if clicking OK has the same effect).

5) Permanent (until restart) grey square.

I don't think that steps 1, 2 are actually necessary... you just need an extension to trigger the HTTP Auth popup.  This leads me to suspect that this bug is the same underlying bug as bug 631346 where Instaright is causing the grey square on startup.  It's probably because Instaright needs a login and if you cancel that popup, you get the grey square.

Yes, this can only be triggered by extensions but I think the underlying bug is actually a Firefox one.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---

Comment 6

5 years ago
In Firefox 20.0 Mac OS X 10.8.3 (12D78) I am using multiple screens and have the Firefox window with tabs not show on the main screen where the menu bar resides at the top. 
When I open the settings window it leaves this grey rectangle in the top left corner on the main screen when closing the settings window.
You need to log in before you can comment on or make changes to this bug.