UndefinedError: 'reviews' is undefined

RESOLVED DUPLICATE of bug 638954

Status

P2
normal
RESOLVED DUPLICATE of bug 638954
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: kumar)

Tracking

Details

(Whiteboard: [traceback], URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/editors/review/127146?num=7

traceback details:

Traceback (most recent call last):

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/preview/zamboni/apps/amo/decorators.py", line 22, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 35, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 252, in review
   return jingo.render(request, 'editors/review.html', ctx)

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 78, in render
   rendered = render_to_string(request, template, context)

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 96, in render_to_string
   return template.render(**get_context())

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/preview/zamboni/apps/editors/templates/editors/review.html", line 1, in top-level template code
   {% extends "editors/base.html" %}

 File "/data/amo_python/www/preview/zamboni/apps/editors/templates/editors/base.html", line 1, in top-level template code
   {% extends "base.html" %}

 File "/data/amo_python/www/preview/zamboni/templates/base.html", line 99, in top-level template code
   {% block main_content %}

 File "/data/amo_python/www/preview/zamboni/templates/base.html", line 104, in block "main_content"
   {% block content %}{% endblock %}

 File "/data/amo_python/www/preview/zamboni/apps/editors/templates/editors/review.html", line 21, in block "content"
   {% include "addons/details_box.html" %}

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/details_box.html", line 190, in top-level template code
   {{ review_list_box(addon=addon, reviews=reviews) }}

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 146, in wrapper
   t = env.get_template(template).render(context)

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/review_list_box.html", line 1, in top-level template code
   {% set reviews = reviews[:3] %}

UndefinedError: 'reviews' is undefined
Assignee: nobody → kumar.mcmillan
Priority: -- → P2
Target Milestone: 6.0.0 → 6.0.1

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638954
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.