asb.co.nz - ASP serving error: application/vnd.wap.xhtml+xml opened as a file due to bad server-side browser sniffing

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: Leman Bennett [Omega], Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110304 Firefox/4.0b13pre
Build Identifier: 

http://forums.mozillazine.org/viewtopic.php?f=23&t=2124947&start=0

Not sure which module to file this under. But here goes nothing.

A user has reported that the listed banking site is not opening properly. Fx4 is being redirected to a mobile site with the normal HTTP flavor (http://www.asb.co.nz/) when every other browser is being redirected to the HTTPS flavor. 

When opening the secure site(https://www.asb.co.nz/) directly, the file dialog opens instead of rendering the page.

The site opens correctly in Fx3.6 and every other current browser that is throw at it.

Reproducible: Always
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
Seamonkey trunk/Firefox trunk User Agent:
Status: HTTP/1.1 200 OK
Connection:	close	
Date:	Mon, 07 Mar 2011 12:41:05 GMT	
Server:	Microsoft-IIS/6.0	
X-Powered-By:	ASP.NET	
X-AspNet-Version:	2.0.50727	
Cache-Control:	no-cache	
Pragma:	no-cache	
Expires:	-1	
Content-Type:	application/vnd.wap.xhtml+xml; charset=utf-8	
Content-Length:	27260

Firefox3 USer Agent:
Status: HTTP/1.1 200 OK
Connection:	close	
Date:	Mon, 07 Mar 2011 12:42:00 GMT	
Server:	Microsoft-IIS/6.0	
X-Powered-By:	ASP.NET	
X-AspNet-Version:	2.0.50727	
Cache-Control:	no-cache	
Pragma:	no-cache	
Expires:	-1	
Content-Type:	text/html; charset=utf-8	
Content-Length:	27260

This is a bug in the page and not Gecko -> TE
Assignee: nobody → english-other
Status: UNCONFIRMED → NEW
Component: Networking: HTTP → English Other
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: networking.http → english-other
Version: Trunk → unspecified

Comment 2

7 years ago
See also the similar bug 637395.
OS: Windows 7 → All
Hardware: x86 → All
Summary: ASP serving error: application/vnd.wap.xhtml+xml opened as a file → asb.co.nz - ASP serving error: application/vnd.wap.xhtml+xml opened as a file due to bad server-side browser sniffing
(Reporter)

Comment 3

7 years ago
Thanks. I suspected bad sniffing originally but wasn't quite sure.
contacted via webform.

Leman Bennett: use http://web-sniffer.net and watch the output with different user Agent settings.
"Thank you for sending through the email that claims to be from ASB Bank.

I can confirm that this is a phishing email and commend you on your
alertness, I have forwarded this to the IT department."

The ELIZA program that they use seems to think that I want to report a phishing email :-(
I guess they moved my mail to /dev/null :-(

Comment 6

7 years ago
I contacted ASB and they resolved the issue within 24 hours of FF4 release.  Site now functions as expected.

Comment 7

7 years ago
Sounds FIXED, then. Please pass our thanks on to ASB.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.