URL status bar hides in-page linked search results at end of page

RESOLVED DUPLICATE of bug 631270

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 631270
7 years ago
7 years ago

People

(Reporter: Axel Knauf, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

Since 4.0b12 the link hover / link target status bar has been moved to the bottom of the window. When performing a search within a page where the next search result is a link and below the currently displayed area, two things happen:
- the page scrolls the visible area to include the search result (making it visible to the user)
- the search result will get focussed (when it is a link)

Getting focussed, the target status bar is displayed at the bottom of the window, effectively hiding the newly focussed search result. 

Reproducible: Always

Steps to Reproduce:
1. Go to the mentioned page (anything with links and length beyond screensize will do): http://www.sonatype.com/books/mvnref-book/reference/public-book.html
2. perform an in-page search for "module"
3. cycle through results until a result beneath the previously displayed area is selected (e. g. using Ctrl-G)
Actual Results:  
The newly focussed search result is hidden by the link target status bar.

Expected Results:  
The search result is not hidden.

The search result should not be hidden, e. g. by scrolling the visible area further so that the link target status bar will be beneath the search result.
(Reporter)

Comment 1

7 years ago
Created attachment 517384 [details]
Screenshot of hidden search result

Attached screenshot of hidden search result as described.

Comment 2

7 years ago
Fixed in latest nightly (http://nightly.mozilla.org/), or else please try
Firefox 4 RC when it is released (~few days)

Also, please search before posting - thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Hardware: x86_64 → x86
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 631270
You need to log in before you can comment on or make changes to this bug.