Closed Bug 639584 Opened 9 years ago Closed 9 years ago

Add exact JS exception and path to binary in spidermonkey failures

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kumar, Assigned: basta)

References

Details

When the wrong spidermonkey binary is used for validation it throws an error about Reflect not being a function.  This gets caught and reported as "spidermonkey is too old."  However, in bug 638945 this might be obscuring some other error.

Please ammend the current exception:
"Spidermonkey version too old; 1.8pre+ required"

So it becomes:
"Spidermonkey version too old; 1.8pre+ required; error='ReferenceError: Reflect is not defined'; spidermonkey='/usr/local/bin/js'"

That should help us debug the real problem.
Assignee: nobody → mbasta
Target Milestone: --- → 6.0.1
Check this out:

https://github.com/mattbasta/amo-validator/commit/257745fb76453dc96b9d3473d306bacd2d5ae3e7

I can't reproduce the error locally, so if you could look it over before I merge it, that'd be swell.
Done:

https://github.com/mozilla/amo-validator/commit/2892e17735aa64f5042c6f93c502d5fe9655711f
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.