Set up syslog and Apache access logs for glow

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: jbalogh, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

7 years ago
I'm using Python's syslog support in the logging module. My syslog tag is http_app_glow and I'm logging to LOG_LOCAL7. Can we hook this up so it goes to the clusterlogs? I don't know where that is past /vol/syslog/clusterlog from khan.

In [3]: logging.handlers.SysLogHandler.LOG_LOCAL7
Out[3]: 23
Unless there is someone else in ops who is familiar with rsyslog and wants to do this tonight, I will take care or it tomorrow morning.
I have the log filtered out to /var/log/glow.log.

As far as the remote logging, it is a bit more complicated than I originally understood.

khan has 10.253.0.11:/vol/syslog/clusterlog mounted which appears to be mpt-netapp-b.mozilla.org.  In that directory are a bunch of app directories.

Where should I forward the syslog messages to have them show up in that directory?
Assignee: deinspanjer → server-ops
Assignee: server-ops → shyam
Duplicate of this bug: 640854
(Reporter)

Updated

7 years ago
Summary: Set up syslog for glow → Set up syslog and Apache access logs for glow
(Reporter)

Comment 4

7 years ago
oremj helped me figure out the zeus logs and I have access to the local glow logs so I don't care about syslog.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.