Port Bug 622379 [Current session data is lost upon browser triggered restart (e.g. upgrade) if the option to clear browsing history upon shutdown is set (again)]

RESOLVED FIXED

Status

SeaMonkey
Session Restore
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Misak Khachatryan, Assigned: Misak Khachatryan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

fix
2.90 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Created attachment 517701 [details] [diff] [review]
fix

From parent bug:

I reporting the same exact problem as was reported in bug 487219.  Basically
the problem is that if the option to "Clear History when <browser> closes" is
checked and then "Browsing History" is also checked, then if the browser is
restarted, the current session is lost.

This was fixed for Firefox 3.6 and still works as of Firefox 3.6.13, but is now
broken again in Firefox 4.0.b8 and the latest 4.0 nightly load.  I've seen this
for myself under Windows and have had it reported to me from someone using OS
X.

I looked at the code and the fix for bug 487219 is still in the code, but
something must have been changed to cause it to no longer work correctly.  I
haven't had a chance to look into it that deeply.

For more details on the original problem see bug 487219.
Attachment #517701 - Flags: review?(neil)

Updated

7 years ago
Attachment #517701 - Flags: review?(neil) → review+
(Assignee)

Comment 1

7 years ago
Pushed: http://hg.mozilla.org/comm-central/rev/6499341dae5e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.