porsche.com - Colors overlap labels during car configuration

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4rc] [bugday-20110401], URL)

Attachments

(1 attachment)

Created attachment 517803 [details]
Screenshot of issue

Seen while running Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

STR:
1. Load http://cc.porsche.com/pva_new/ccCall.do?userID=US&lang=us&PARAM=parameter_internet_us&vLevel=2
2. Notice how the colors overlap the labels

Happens on Mac as well using the same build ID. On Mac I checked Safari and Chrome and in both browsers it displayed correctly.
(Reporter)

Updated

8 years ago
Summary: Colors overlap during car configuration → Colors overlap labels during car configuration
Did this work in 3.6?  The site serves somewhat different styles to us and Chrome, as far as I can tell...
Hmm, this is WFM on Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre ID:20110303122446 and Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.16pre) Gecko/20110308 Namoroka/3.6.16pre ID:20110308033207.
Might depend on your default fonts, the fonts installed on your machine, the minimum font size, on Windows on whether you're getting dwrite or not, etc...
Using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 on the same machine it does work for me.
Using on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre ID:20110303122446 I can repro the Issue.

With gfx.direct2d.disabled;true & gfx.font_rendering.directwrite.enabled;true => Issue

With gfx.direct2d.disabled;true & gfx.font_rendering.directwrite.enabled;false => no Issue

=> DirectWrite Issue or expected due to different Font Rendering?
What could cause this happen on MacOS too?
Component: Layout → Graphics
QA Contact: layout → thebes
The site is assuming that a particular pixel width will fit text with a particular font-family and font-size style.

In other words it's making assumptions about the fonts horizontal metrics.

This is a bogus assumption if the font is slightly different (e.g. Windows vs Mac) or the font rasterization engine does different glyph positioning (e.g. dwrite vs gdi).

This is really looking like an evangelism bug to me...

Comment 7

8 years ago
If you disable the hardware acceleration, it works fine.

Go to option > advanced > uncheck "use hardware acceleration when available".
> TE
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Graphics → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: thebes → english-us
Whiteboard: [4rc] → [4rc] [fx4-unco-bugday]
Version: Trunk → unspecified

Comment 9

8 years ago
Adjusting title to TE preferred format.
Summary: Colors overlap labels during car configuration → porsche.com - Colors overlap labels during car configuration

Comment 10

8 years ago
WFM.

Windows Vista 32-bit.
Build identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre
Shockwave Flash 10.3.180.65 Beta 2
Whiteboard: [4rc] [fx4-unco-bugday] → [4rc] [bugday-20110401]
Marcia, can you still reproduce this in Minefield (as per comment 10)?

Comment 12

8 years ago
(In reply to comment #10)
> WFM.
> 
> Windows Vista 32-bit.
> Build identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110331
> Firefox/4.2a1pre
> Shockwave Flash 10.3.180.65 Beta 2

With HA on?

Comment 13

8 years ago
(In reply to comment #12)
> (In reply to comment #10)
> > WFM.
> > 
> > Windows Vista 32-bit.
> > Build identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.2a1pre) Gecko/20110331
> > Firefox/4.2a1pre
> > Shockwave Flash 10.3.180.65 Beta 2
> 
> With HA on?

Yes.
Using the latest trunk nightly on one Windows 7 machine, I am unable to reproduce. I will try the other machines I have as well.

(In reply to comment #11)
> Marcia, can you still reproduce this in Minefield (as per comment 10)?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110401 Firefox/4.2a1pre on another machine, I still see the issue. When I pref off Hardware acceleration the issue does not occur.
This was on a different machine from the one tested in Comment 14.

(In reply to comment #15)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110401
> Firefox/4.2a1pre on another machine, I still see the issue. When I pref off
> Hardware acceleration the issue does not occur.
On this Windows 7 laptop, hardware acceleration is pref'd on and the issue does not manifest itself. So it might be machine dependent.

(In reply to comment #14)
> Using the latest trunk nightly on one Windows 7 machine, I am unable to
> reproduce. I will try the other machines I have as well.
> 
> (In reply to comment #11)
> > Marcia, can you still reproduce this in Minefield (as per comment 10)?
This site doesn't seem to be maintained anymore in any browsers. I have a consistent result with a broken header. As for the bug, I didn't notice anything wrong.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.