Make 'Tested upon' field optional for pending updates

VERIFIED FIXED in 6.0.2

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P2
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: gkoberger)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 517853 [details]
screenshot

steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/editors/review/394267?num=1
2. Click on 'Grant Preliminary review'
3. Add a review comment and click 'Save'


expected behavior:
Review is successful 

observed behavior:
Review is unsuccessful because 'Tested upon:apps' and 'Tested upon:OS' are required fields

We should make those fields optional.
Assignee: nobody → gkoberger
Priority: -- → P2
Target Milestone: 6.0.1 → 6.0.2
Whiteboard: [post-freeze+]
Target Milestone: 6.0.2 → 6.0.1
Whiteboard: [post-freeze+]
Target Milestone: 6.0.1 → 6.0.2
(Assignee)

Comment 1

7 years ago
Additionally, we should hide it for the "Request ____" options.
(Assignee)

Comment 2

7 years ago
It should be optional for everything, and not even show up if you pick "Request more info" or "Request super review"

https://github.com/jbalogh/zamboni/commit/ac3635481ecc7898a4bf6f8ff408c53009ac976b
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
Tested upon info is an optional field for all reviews. Marking this as verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

7 years ago
Created attachment 520363 [details]
post-fix screenshot

Tested upon info doesn't show up super review or request more info
(Reporter)

Comment 5

7 years ago
Created attachment 520364 [details]
post
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.