swap disk frequently, speed become slow ( it seems memory low) when open for long time (> 4 hrs, even not in use)

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Danny Shum, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    20001230

We use Red Hat 6 on a PC with 64MB RAM and we run mozilla only. 

After runing mozilla for some hours (say >4 hrs), 
the PC become very slow. 
The PC busy swap disk. 
It seems memory low.

- The promblem CANNOT be solved by quit & restart mozilla.
- After add RAM to 128MB, the problem happens later.

Reproducible: Always
Steps to Reproduce:
1. Use Red Hat 6 on a PC with 64MB RAM and run mozilla only. 
2. Mozilla states open for some hours (say >4 hrs), 


Actual Results:  The PC become very slow. 
The PC busy swap disk. 
It seems memory low.


Expected Results:  The PC have fast response.
The PC do not busy swap disk.

1. Only reboot the PC can help.
2. Restart mozilla cannot help.
3. After add RAM to 128MB, the problem happens later.
4. The problem happens even the broswer states open but not is use for long 
time.
5. associated with a message ">>>>>> Write clipboard to memory"

Comment 1

17 years ago
Please see also bug 58870, and check out all the tips mentioned there to try to 
fix this problem. Could you tell us if any of those tips fixed your problem?
Are you using RH6 or RH6.1 or RH6.2? (It makes a difference for Mozilla).
Thanks,
Fabian.

Comment 2

17 years ago
Reducing severity. Reporter, if you believe what you are seeing is indeed that
described in bug 58870 then feel free to mark this bug a duplicate or comment in
here that it should be so.

If you believe you're seeing something different, please comment that this bug
should be further investigated within 10 days, else others may mark this bug a
duplicate.
Severity: blocker → critical

Comment 3

17 years ago
Please include swap file size, and X version, and window manager and other 
similar random variables.
(Reporter)

Comment 4

17 years ago
The problem is exactly the same as bug#58870. 
Here is the config of my system:
X Window Version  XFree86 4.0.1-1
Linux RH 7.0
Mozilla 0.6

DannyShum

*** This bug has been marked as a duplicate of 58870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified dupe of bug 58870: "BAD: slowly eats all memory up to SWAP end."
As the reporter said so...
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
This is not a dup of 58870.

dannyshum@usa.net: I cannot believe that mozilla would wedge Linux so badly as
to require a reboot, but I *could* believe that your X server has consumed
enough memory that *it* needs to be kicked.

Could you please do the following:

1. Take your 64MB linux box and get it into a state where mozilla has wedged it
good.

2. Run `ps aux > /tmp/process.txt', and attach that file to this bug report (or
copy and paste it into the bug report).

3. Bounce your X server (e.g., `telinit 3 ; sleep 60 ; telinit 5' if you start
in runlevel 5). Does performance still suck?
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

17 years ago
Reporter any luck reproducing this bug using the steps provided by Chris?

Comment 8

17 years ago
Marking WORKSFORME due to lack of response. Reopen when/if we get more
information about the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.